Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Issues with wireless enabling

  1. #11
    Senior Member
    Join Date
    Apr 2008


    Quote Originally Posted by ricky View Post
    Could someone please help me with my issue which, I posted earlier but still no reply on it.

    I am using HP laptop DV9605ea with broadcom chipset. Using Bactrack 3 usb version. To find out the actual chipset when I use lspci it shows 'BCM4312 (rev 02)' and in iwconfig it shows 'nickname BCM4311' (sorry for that, as unsure of it). My interface is eth1. iwlist scan always says 'No scan results'. When I try to connect through a terminal window and have to down the eth1 then I cannot make it up. If I try to run command 'ifconfig eth1 up' it says 'error no such device'.

    I have searched alot in this forum for my issue but coudn't find a satisfactory answer. I also googled for the solution of my problem but all in vain.

    1. I did find some soultion like to use bcm43xx fwcutter but same results again.
    2. I tried to use Ndiswrapper by following the instructions on the link (It won't allow me to put link)
    Ubuntu forms: Feisty_No-Fluff
    but got stuck here:
    sudo cp /etc/network/interfaces /etc/network/interfaces.orig
    echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
    sudo ndiswrapper -m
    echo 'ndiswrapper' | sudo tee -a /etc/modules
    echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant
    3. The only instructions worked for me were at broadcom website itself.

    But the problem with those instructions are after connecting to internet, using iwconfig command nickname of my eth1 chipset is gone it just shows blank in quotes " " and only the first letter of my essid. Further, I cannot configure kismet source line with these instructions as they asked to remove the bcmxx. I been trying to resolve this issue from last 4 days but still unable to figure it out.

    Any help in this matter is highly appreciatable
    Ndiswrapper does not support monitor mode which means that you will not be able to crack WEP/WPA using that driver, or even get kismet to work. On the other hand what you do need is the b43 driver, but to get them to work on BT3 you will need to upgrade the kernel version, which is no easy task for a beginner. Personally my advice would be to get another wireless card that is supported out of the box and save yourself from a lot of headaches.
    -Monkeys are like nature's humans.

  2. #12
    Just burned his ISO
    Join Date
    Apr 2007


    i came across the great knowledge from a UBUNTU site that the wext drivers could possibly have compatibility with such bcm4311/4312 chip, hope this info helps a bit

  3. #13
    Just burned his ISO
    Join Date
    Sep 2008


    Quote Originally Posted by clndwhr View Post
    i came across the great knowledge from a UBUNTU site that the wext drivers could possibly have compatibility with such bcm4311/4312 chip, hope this info helps a bit
    I am using ubuntu as well and have no problems with that. It is using B43 with my chipset. Further, I am able to fix the issue by following the steps:

    1. Download hybrid-portsrc-x86_32_5_10_27_6.tar.gz files from broadcom website.

    2. Untar the file. hybrid_wl

    make -C /lib/modules/ M=`pwd` clean

    make -C /lib/modules/ M=`pwd`

    rmmod bcm43xx

    rmmod b43; rmmod b43legacy
    modprobe ieee80211_crypt_tkip

    insmod /root/Desktop/hybrid_wl/wl.ko

    editing /etc/modprobe.d/blacklist
    and add the following to the end of the file:

    blacklist b43

    blacklist b43legacy

    blacklist bcm43xx

    mkdir /lib/modules/

    mv wl.ko /lib/modules/

    depmod -a

    echo wl |sudo tee -a /etc/modules

    modprobe wl

    my wifi works fine with that but the issue with this is my chipset id is gone. I cannot use aircrack-ng pack or kismet or any other tool.

    nyway thanks for the info. will try that as well.

    thanks again.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts