Results 1 to 3 of 3

Thread: Broadcom 4312 issue again..

  1. #1
    Just burned his ISO
    Join Date
    Sep 2008

    Default Broadcom 4312 issue again..

    Hi All,

    First of all I would like to greet to everyone here and then my thanks to all members of this forums who keep posting valuable information. I am new to this forum and this is my first post. I will not say that I am new to linux but at the same time I'll also not say that I am very good in Linux. I've been using Ubuntu 8.04 from last 6 months now without any issue. Here is my issue:

    I am using HP laptop DV9605ea with broadcom chipset. Using Bactrack 3 usb version. To find out the actual chipset when I use lspci it shows 'BCM4312 (rev 02)' and in iwconfig it shows 'nickname BCM4311' (sorry for that, as unsure of it). My interface is eth1. iwlist scan always says 'No scan results'. When I try to connect through a terminal window and have to down the eth1 then I cannot make it up. If I try to run command 'ifconfig eth1 up' it says 'error no such device'.

    I have searched alot in this forum for my issue but coudn't find a satisfactory answer. I also googled for the solution of my problem but all in vain.

    1. I did find some soultion like to use bcm43xx fwcutter but same results again.
    2. I tried to use Ndiswrapper by following the instructions on the link (It won't allow me to put link)
    Ubuntu forms: Feisty_No-Fluff
    but got stuck here:
    sudo cp /etc/network/interfaces /etc/network/interfaces.orig
    echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
    sudo ndiswrapper -m
    echo 'ndiswrapper' | sudo tee -a /etc/modules
    echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant
    3. The only instructions worked for me were at broadcom website itself.

    But the problem with those instructions are after connecting to internet, using iwconfig command nickname of my eth1 chipset is gone it just shows blank in quotes " " and only the first letter of my essid. Further, I cannot configure kismet source line with these instructions as they asked to remove the bcmxx. I been trying to resolve this issue from last 4 days but still unable to figure it out.

    Any help in this matter is highly appreciatable.

  2. #2
    Just burned his ISO
    Join Date
    Sep 2008


    The only sol. I could find was:

    1. Download hybrid-portsrc-x86_32_5_10_27_6.tar.gz file from broadcom website.

    2. Untar the file. hybrid_wl

    make -C /lib/modules/ M=`pwd` clean

    make -C /lib/modules/ M=`pwd`

    rmmod bcm43xx

    rmmod b43; rmmod b43legacy
    modprobe ieee80211_crypt_tkip

    insmod /root/Desktop/hybrid_wl/wl.ko

    editing /etc/modprobe.d/blacklist
    and add the following to the end of the file:

    blacklist b43

    blacklist b43legacy

    blacklist bcm43xx

    mkdir /lib/modules/

    mv wl.ko /lib/modules/

    depmod -a

    echo wl |sudo tee -a /etc/modules

    modprobe wl

    Now the problem is my wifi works fine with that but the issue with this is, my chipset id is gone. I cannot use aircrack-ng pack or kismet or any other tool.

    Has anyone got better solution please.


  3. #3
    Just burned his ISO
    Join Date
    Sep 2008


    When I execute 'bt hybrid_wl # make -C /lib/modules/ M=`pwd` I recieve

    make: *** /lib/modules/ No such file or directory. Stop.

    Am I doing something wrong?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts