Hi all,

I'm fiddling with BackTrack3 and my EeePC. So far I've written the USB image to an SD card and booted from there, which works fine and dandy. From here I have two questions:

1) Not using a ramdisk, but installing BT3 to the SD Card
Would I see increased or decreased performance if I installed BT3 to the SD card? Is this a 'good' thing to do? I've been trying but have run into a problem. So far I've followed Purehate's tutorial:

bt~#mkdir /mnt/backtrack
bt~#mount /dev/sda1 /mnt/backtrack/
bt~#mkdir /mnt/backtrack/boot/
bt~#cp --preserve -R /{bin,dev,home,pentest,root,usr,etc,lib,opt,sbin,va r} /mnt/backtrack/
bt~#mkdir /mnt/backtrack/{mnt,proc,sys,tmp}
bt~#mount --bind /dev/ /mnt/backtrack/dev/
bt~#mount -t proc proc /mnt/backtrack/proc/
bt~#cp /boot/vmlinuz /mnt/backtrack/boot/
bt~#chroot /mnt/backtrack/ /bin/bash

I then downloaded Grub2 to /mnt/backtrack/ and did a ./configure && make && make install

bt~#grub-install /dev/sda
bt~#grub-setup /dev/sda

I then edit grub.cfg such that:

menuentry "Moobar"{
	set root=(hd0,1)
	linux /boot/vmlinuz root=/dev/sda1 ro autoexec=xconf
	#initrd /initrd

Which seems to find the kernel and it starts booting, but then it halts on:

VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to moujnt root fs on unknown-block(0,0)
I tried using Grub after getting the same error with LILO, so I guess I'm doing something else wrong (and probably silly). Please could someone advice me on how to work out what the correct "boot=foo" option would be? Or if I'm doing something else wrong..

2)Modifying the USB Image
Question two. Is it possible to modify the the USB image? If so, what tools/techniques can I use? For example, I'd like to permanently edit the kismet.conf on the BT3 USB image such that I don't need to modify it manually every time I boot.

Sorry if these questions have been asked/answered already on the forum, perhaps my searching fu couldn't find them