Results 1 to 2 of 2

Thread: cant USB boot

  1. #1
    Just burned his ISO
    Join Date
    Aug 2008

    Default cant USB boot

    First of all hi.

    I have downloaded the the BT3 final USB version (i wanted the john-mpi functionality). I can confirm that the md5 matches the supplied one on the download page. I have installed BT2, BT3b1 and BT3 CD versions before. The method i have used for installation is to :

    1. mount the iso
    2. copy the two directorys (BT3 and boot) to my target partition (a usb drive)
    3. ran 'bootinst script' (i have tried this under linux and under 'dows)

    Using a similar method i have been able to install BT2, BT3b1, BT3 CD fine. I have a copy on my HDD. Now i want to install a copy to a USB flash drive. Syslinux runs fine, installs lilo. When the USB drive is selected to be boot from the lilo screen appears. The kernel boots. Then initrd fires up as well till it gets to the part 'fatal error occured - no bt3 data not found'. I have downloaded and confirmed the validity of the file twice. I have installed both twice and gotten the same error. I have tried a harddrive install and gotten the same error. When it craps out looking for BT3 data i am able to mount my usb drive and see the BT3 directory. I have even changed the lilo conf to look for the kernel and initrd from the BT3 directory and they booted but still had the same problem.

    If I append the kernel parameter 'debug' to the kernel line at lilo it stops at where it is failing to find BT3 data saying it cannot find 'livecd.sgn'. Upon looking in this file it says it is there to tell linuxrc where to mount the live file system. The livecd.sgn is in the BT3 directory the same as my other install of BT3.

    So i have tried everything i can think off. I just cant make this mutha f****a boot. What is going wrong?

    What i would like is either:

    1. The 'extended USB version on my USB drive as a live install'
    2. or a pointer to some info as to how i get and install the john-mpi cluster modules into the 'CD' version.

    I see some other people are having the same problem but i see that it has not been solved yet.


  2. #2
    Just burned his ISO
    Join Date
    Aug 2008


    usually being one to answer my own questions...

    It turns out that by using the 'nohd' option while running from a poorman's install will indeed mean nohd. I.e. no usb drive either!

    The reason i was doing this was to try and force BT3 to boot from the USB drive. The thing that was happening was i would boot from the drive and it would find the BT3 datas on my HDD thus only loading the kernel and initrd from the USB drive!


    However my original question still stands. What modules must i swap in from the USB version to the CD version to get PXE john-mpi functionality?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts