Alright so I am trying to boot bt3 from a partitioned usb drive to allow me to save changes. Fallowing the instructions I got bt3 to boot just fine using a brand new unpartitioned flash drive. Then I downloaded a new driver for my usb that tricks the computer into thinking its a non-removable disk (the driver is a Hitachi Microdrive driver). From there I partitioned a FAT32 section just under 1.5gb leaving .5gb for the changes partition. I ran boot.bat and had to make the ( -f) changes. When attempting to boot my computer recognizes I has a usb drive but upon attempting to boot it give a "operating system not found" error and boots to windows from the hard drive. I have tried changing the flash drive driver back the the original but was unable to find a copy so I settled for the one windows gave me. It then reads the flash drive as a removable disk as it should. I have tried using boot.bat with and without the ( -f) change and it still gives me the same message. I have also tried removing the partition and it makes no difference. Any help would be greatly appreciated as I have not been able to find any information about this specific problem. Actually if anyone knows how to get a new usb driver that works for booting I would be very happy.