Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: How To Use New Enhanced features Of rt73 chipset and WPA_Supplicant Issues Fixed

  1. #1
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    在這兩者之間 BackTrack是4 FwdTrack4

    Thumbs up How To Use New Enhanced features Of rt73 module and WPA_Supplicant Issues Fixed

    Tested on hardware Linksys WUSB54GC rt73 chipset based.

    there is new update for rt73 chipset based cards.first download the latest modules.

    working with wpa_supplicant.
    you need to patch wpa_supplicant
    use the next generation rt2x00 driver which is compatible with wpa_supplicant
    latest modules of rt73 have in-built private ioctls to support wpa_supplicant like config.

    Ok we begin
    extract archive

    ifconfig rausb0 down
    modprobe -r rt73
    cd rt73-k2wrlz-3.0.1/module
    make && make install

    modprobe rt73 ifname=rausb0 or wlan0
    (here you can choose the appropriate name according to your choice like wlan0 or rausb0 or eth1 whatever)

    now use the iwpriv command to avaliable private ioctls
    iwpriv wlan0

    bt ~ # iwpriv wlan0
    wlan0 Available private ioctls :
    set (8BE2) : set 1024 char & get 0
    txpower (8BF3) : set 1024 char & get 1024 char
    adhocOfdm (8BE6) : set 1 int & get 0
    stat (8BE9) : set 1024 char & get 1024 char
    get_site_survey (8BEF) : set 1024 char & get 1024 char
    get_RaAP_Cfg (8BF1) : set 1024 char & get 0
    forceprism (8BF2) : set 1024 char & get 0
    rfmontx (8BEC) : set 1024 char & get 0
    get_rfmontx (8BED) : set 0 & get 1 int
    auth (8BE7) : set 1 int & get 0
    enc (8BE8) : set 1 int & get 0
    wpapsk (8BEA) : set 64 char & get 0
    psm (8BEB) : set 1 int & get 0

    you are able to see that we got options like txpower and wpapsk,auth,enc etc to modify the settings.

    if you want to set the txpower output.use
    ifconfig wlan0 down
    modprobe -r rt73
    modprobe rt73 txPowerTuning=36 ifname=wlan0
    Remember: This value will be ADDED to the default Power stored in the card's EEPROM!
    Valid Values for Transmit Power: -6 to 36 (0xFA to 0x24).
    I set it on my Linksys WUSB54GC as 36 without problem.
    now you can use

    it will show the USB NIC interface as newly created wlan0

    use airodump-ng wlan0

    you will get pwr much more then before.I got amazingly 90 to 110.

    now you have options to use and work with WPA/WPA2 networks.
    first option as already told use latest rt2x00 drivers from serialmonkey or configure the wlan0 USB NIC as following

    b) WPA (802.11g)

    wpa_passphrase <essid> <passphrase>
    copy the psk hash(uncommented one)
    iwconfig wlan0 mode managed
    iwpriv wlan0 set AuthMode=WPAPSK
    iwpriv wlan0 set WPAPSK=<key> #replace key with your psk-hash
    iwpriv wlan0 set EncrypType=TKIP

    c) WPA2 (802.11i)
    wpa_passphrase <essid> <passphrase>
    copy the psk hash(uncommented one)
    iwpriv wlan0 set AuthMode=WPA2PSK
    iwpriv wlan0 set WPAPSK=<KEY> #replace key with your psk-hash
    iwpriv wlan0 set EncrypType=AES

    Check that you're associated with an AP
    iwconfig wlan0

    if you want to patch wpa_supplicant for rt73 chipset you need to patch
    the wpa_supplicant file to work with rt73 based chipset
    download wpa_Supplicant & patch files here.


    tar xzf wpa_supplicant-0.5.7.tar.gz
    cd wpa_supplicant-0.5.7
    patch -p1 < wpa_supplicant-ralink_rt73.patch
    patch -p1 < wpa_supplicant-ralink_rt73-fix.patch
    # install as usual, e.g.
    cp wpa_cli wpa_supplicant /usr/local/bin

    configure using wpa_supplicant(other users who looking for wpa_supplicant config. can try this)

    use these commands

    wpa_passphrase <essid> <passphrase>
    bt ~ # wpa_passphrase thunderbolt backtrack3
    psk=7b8e62496b86b7eba28199fd9af1f560a8503b7ede9149 bd2f42e42e631bedb0
    copy the psk-hash

    for configuring wpa_supplicant
    nano /etc/wpa_supplicant.conf

    edit it
    # WPA protected network, supply your own ESSID and WPAPSK here:
    scan_ssid=0 #1 is ssid is hidden
    ssid="thunderbolt" #change with your ssid/essid
    pairwise=CCMP TKIP
    group=CCMP TKIP WEP104 WEP40
    psk=7b8e62496b86b7eba28199fd9af1f560a8503b7ede9149 bd2f42e42e631bedb0
    # change the psk hash with your psk hash you got from wpa_passphrase

    now connect with WPA/WPA2 enable AP using

    bt ~ # wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf - d rt73 -w (other user may change to ath0-madwifi-ng,wifi0)

    Trying to associate with 00:21:29:68:16:c2 (SSID='thunderbolt' freq=2462 MHz)

    Associated with 00:21:29:68:16:c2
    WPA: Key negotiation completed with 00:21:29:68:16:c2 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:21:29:68:16:c2 completed (auth) [id=0 id_str=]

    Here you done configuring txpower for new rt73 module,configuring wpa/wpa2.hope you all liked this little hardware hacks and configs.

  2. #2
    Junior Member
    Join Date
    Sep 2007


    tnx, with the 3.01 driver the spoonwep2 AND airoscript finaly working with my edimax and dlink rt73 devices.

    got backtrack 3final.

  3. #3
    Just burned his ISO voodoosau's Avatar
    Join Date
    Jul 2008


    i have following problems:

    1. i'm a linux noob (ok, time will solve the problem ;-) )
    2. i'm on a virtual machine running bt3final. i downloaded the package to root folder, extracted with arc, then in konsole i go to #module and type "make". following error apears:

    bt Module # make
    make: *** /lib/modules/ No such file or directory. Stop.
    rt73.ko failed to build!
    make: *** [module] Error 1

    when i'm on bt3final_usb.iso in this virtual machine everything works fine for me with this install procedure.

    tell me: what is the NOOB doin' wrong? ;-)

  4. #4
    Senior Member
    Join Date
    Apr 2008


    On the live CD version of BT3 the kernel headers, which is what you need here, are stripped out for BT3 to fit onto a single CD. You can however download them at the following location:

    After downloading use the following command:
    lzm2dir kernel.lzm /

    This should sort out the problems you are having.
    -Monkeys are like nature's humans.

  5. #5
    Just burned his ISO voodoosau's Avatar
    Join Date
    Jul 2008


    quick and short:

    ok, now it works under the bt3final.iso with the kernel headers.

    thanks a lot, i'll keep on learning ;-)

  6. #6
    Just burned his ISO
    Join Date
    Aug 2008


    Hi this is my first post, i have searched around for an answer to this but have had no luck.


    ive followed the guide above and updated the rt73 drivers and set txpower to 36. with no problems

    im trying to connect to my WPA-PSK network but not having any success.

    iwconfig rausb0 mode managed
    iwpriv rausb0 set AuthMode=WPAPSK
    iwpriv rausb0 set WPAPSK=...pasted from wpa_passphrase..
    iwpriv rausb0 set EncrypType=TKIP

    iwconfig rausb0 then shows the essid but the encryption key there is either none or a completely different hash! so i obviously cant get an ip with dhcpcd

    Can someone give me a little help out with this please im lost as to why the keys showing as different?

    i havnt tried patching wpa_supplicant as mentioned in the guide as i obviously have no internet connection with backtrack. well unless i switch the router to WEP which i dont really want.

  7. #7
    Join Date
    Jun 2008


    Great tutorial, thanks.

    Did you try loading kwlan then
    wpa_supplicant -i rausb0 -c /etc/wpa_supplicant.conf - d rt73 -w
    Also, not sure if it helps but did you try the key in "" marks?

  8. #8
    Just burned his ISO
    Join Date
    Jun 2008


    Great tutorial secure_it thanks!

  9. #9
    Just burned his ISO
    Join Date
    Jan 2010


    I'm trying to install the new driver as per the tutorial (BT3F installed to hdd) and keep running up against the following issue. I have extracted the driver to /tmp. Every time I try to run "cd /rt73-k2wrlz-3.0.1/module I get "No such file or directory".

    I'm assuming that its a permissions thing but I can't work out what I need to change and how!

  10. #10
    Junior Member
    Join Date
    Mar 2008


    you are logged in as root, I doupt it could be a permissions issue. Try /tmp/rt73-k2wrlz-3.0.1/ since you say you extracted it to the /tmp folder.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts