Results 1 to 6 of 6

Thread: Wireless D-Link WUA-1340 USB NIC Setup Issue

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008

    Default Wireless D-Link WUA-1340 USB NIC Setup Issue

    I'm new to Linux and BackTrack. I am trying to get my USB wireless device setup and running so I can practice cracking WEP, etc... Below is what I am doing so far and I cannot get the USB wireless to work.

    From what I have read this is what I need to do to get things to work:
    1. Hardware Support for the wireless USB Nic
    2. Config the card to connect to a WAP
    3. Config the Network

    This is what I have done with the above steps:
    1.Hardware support for the wireless USB Nic:
    - I have done nothing here as I am assuming BackTrack 3 is already setup with the Rt73 driver, as advised on the BackTrack wiki page.

    Is there anything that I should be doing here?

    2. Config the card to connect to a WAP
    - I have opened rc.wirless.conf and edited it with the following entry.

    # Connect to WAP*)
    INFO="Dlink WUA-1340"
    KEY="128 byte key here"

    Next I ran "rc.wireless" and then "rc.inet1"

    Next I ran the following commands:
    iwconfig rausb0 essid "MyNetworkName"
    iwconfig rausb0 key 128 byte key here
    iwconfig rausb0 channel 5

    Have I done this correctly and is there anything I am missing here?

    3. Config the Network

    What do I need to do here?

  2. #2
    Senior Member
    Join Date
    Apr 2008


    As you mention that you use a 128 bit key I will assume that you are trying to connect to a WEP encrypted AP. These are the only steps that should be required to connect through the command line:
    rm /etc/dhcpc/*
    dhcpcd –k rausb0
    iwconfig rausb0 mode managed
    iwconfig rausb0 essid "MyNetworkName"
    iwconfig rausb0 key ”your WEP key in hex form, ie 01122…”
    ifconfig rausb0 up
    dhcpcd –d –n rausb0
    The first two steps are to make sure that you do not have a dhcpcd client currently running and no previous settings in your /etc/dhcpc/ directory that could interfere with the process. Also you want to make sure that you wait after issuing the ifconfig rausb0 up command until your wireless card has locked onto your AP before using the final command. you can check the process by in an additional shell window using the command watch iwconfig rausb0.
    -Monkeys are like nature's humans.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2008


    Thanks for the help =Tron= it's greatly appreciated.

    When I opened the wireless assistant it started scanning for networks and appeared to work, but then I received the error message below.

    Error Message From Wireless Assistant:
    "Radio of your wireless card seems to be turned off using an external switch on your computer. You need to turn it on to be able to use wireless networks."

    I checked kismet to see if it was working, but no luck. There is no external switch on the USB wireless device (D-Link WUA-1340). I am running a Dell Inspiron 1150 laptop if this helps anyone.

    Does anyone have any ideas as to whats going on here?

    Thanks in advance and I appreciate any help you can provide.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009



    Did this ever get resolved? I have the same problem and hunting for an answer.


  5. #5
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    在這兩者之間 BackTrack是4 FwdTrack4


    Wireless GUI have some known problems like connect & then disconnect issue.the recommended solution is to use command line configuration.

  6. #6
    Just burned his ISO
    Join Date
    Jul 2009

    Default Same problem but the adapter was working earlier...

    I am having the same problem as described by spec36... My USB adapter is a Linksys WUSB54GC. I am running the VMWare version of Backtrack 3 on a Windows XP partition on my MacPro desktop.

    The strange thing is that the USB adapter was working last week when I first set it up. In fact, I successfully got it to crack a WEP AP using the command line steps in the shell. When I tried again some days later, the "airodump-ng" shell command did not display any APs at all. So I tried using the Wireless Manager and got the message "Radio of your wireless card seem to be turned off using an external switch..."

    Aside from shutting down the Backtrack 3 VM and restarting into Windows and Mac OSX, I don't believe anything has been changed. My USB adapter is showing up when I type "airmon-ng ra0" and when I run the shell commands in Backtrack 3 to change its MAC, it accepts the changes. It is also showing up in the Kismet drop down menu but I have not been able to get SpoonWep to work from the start. If I select it from the menu, nothing happens...

    So something seems to be changing the "radio" state of the adapter, and I have not been able to find anything on how to check the "real" status of the adapter, or how I might get this problem fixed.

    Thanks for any help !!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts