Hi all,

I have a 2 year old MacBook Pro that has the ATI Radeon X1600 in it. If I boot off a BT3 live CD and choose VESA mode X11 starts up fine and everything works.

I installed BT3 on a disk partition using the information posted in the howto's and it boots up fine and I'm able to run various utilities from the console, however I've been unable to get X11 to work at all in this case. I've tried running xconfig, I've tried manually copying /etc/X11/xorg.conf-vesa to xorg.conf and using that, I've even gone so far as to boot off the live CD and copy its xorg.conf that I know works onto a usb stick then reboot to the hard drive, install that xorg.conf, and try that.

If I use the vesa version of xorg.conf I get the error "(EE) AIGLX: DRI module not loaded". If I add the DRI module to the xorg.conf I get "(EE) AIGLX: Screen 0 is not DRI capable".

I've also tried using different vga=lines in my lilo.conf but if I use values other than 791 then each time I try to run startx and it bounces me back to the command line then the screen gets fainter & fainter until I can't see anything, and I have to reboot to be able to see anything again...

Any suggestions on how to get this to work? Thanks in advance!