Hey guys,

I am still pretty new to Backtrack, and am having a few issues that i hope you can help me out with. I seem to be having issues with getting into wicd to connect to a wireless or wired network for that matter. This used to be working, however i was playing around a bit cracking our 128 bit WEP key at my office for security reasons, and ever since then, backtrack wont seem to start wicd or my network connection. This is my major concern out of all of my issues.

Also, another issue i am having is getting applications via the CLI with the syntax apt-get. I have tried to do an apt-get install dist-upgrade, as well as apt-get install upgrade, apt-get install update, but i seem to be getting some errors. (This was all before my networking issue, when my network connections were working). I have all of the repo's selected within the software sources. I am trying to install iperf for throughput testing, as we use it very frequently at my work.

One more very minor thing, i was playing around with customization, and selected something which puts a (mac os - like) toolbar on the top of the screen. This toolbar takes place of the file menu within applications. I would like to take this off, but cant remember what i did to select it .

I would like most to get most of these issues worked out before i make backtrack my primary work OS.

ANY help is GREATLY appreciated!!