Apart from my Edimax[rt73], I have a built in Atheros AR5BMB5 card on my laptop and it does not work out of the box.

It's more than likely the exact same problem I had with my Edimax EW-7318USg. More than likely modprobe will work, but I am currently on BT3Beta therefor my test results and diagnosis will have to wait until tomorrow morning.

I don't have a problem with it, I never have any problem with BT because it's free and I respect that. Although again I am curious to know why this card worked out of the box with BT3b and not the final?

It was actually quite funny when neither of my cards worked when I loaded BT3_Final, I had to load BT3b to get on this forum to post the bugs. Again, I am not crying about it, that would be childish; anyway I have my Edimax card sorted for BT3_Final

EDIT: Forgot to throw in some diagnostic results/device lists:

bt ~ # lspci
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 IDE interface: ATI Technologies Inc 4379 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
09:01.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
09:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
09:04.0 Ethernet controller: Atheros Communications, Inc. AR2413 802.11bg NIC (rev 01)
bt ~ # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"BTHomeHub-****"  Nickname:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:**:**:**:**:**
          Bit Rate:12 Mb/s   Tx-Power:16 dBm   Sensitivity=1/1
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-**   Security mode:open
          Power Management:off
          Link Quality=9/70  Signal level=-87 dBm  Noise level=-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Ok no need to add any further device details, problem solved...I found the problem! I need a new laptop!!! Thats the bloody problem. I can not understand that my Atheros AR5BMB5 wasn't working on my first boot of BT3final. When I first booted, my card was seen by the OS, it was also seen in iwconfig; but when I tried to connect to my AP it would not connect. I even tried the GUI Wireless Assistant and it did not even show any networks in range - Dhcpcd did not register either on CL...I also noticed the new system tray icon that kept stating 'ath0 is trying to aqquire an IP Address for over 10mins before giving up.

After loading into BT3b, then back onto BT3_Final my card works. After this thread and the other 'DVD' thread I created...I am beginning to think my laptop is on its way out. Hey..at least if someone else gets the problem, they will know that the problem lays within their pathetic laptop

Mods/Admin can you delete this thread? Unless you think it may actually serve a purpose, I don't think it will but someone may. How strange my BT3_Final adventure has began with several wild and embarrassing errors I have been encountering.