Results 1 to 2 of 2

Thread: Trouble With startx with ATI

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008

    Default Trouble With startx with ATI~SOLVED


    I have a Fujitsu-Siemens Amilo Si 1848+u notebook, with an X1300 Ati card in it.
    I have already installed to the HD the BT3 Usb version (I've got a lot errors booting, the plain version, so a burned to DVD the Usb version).
    The only mode to boot up the Dvd is the VESA KDE mode, othervise, when i log in, and type startx , it writes that no monitor devices, and Fatal error.
    So i used Vesa Kde mode, with it i can use the Live Cd.

    I followed the steps in the installation guide, and I could do it
    but the only problem is that, I having the same problem, like when I was trying the Live cd.
    So I decided to boot up in GRUB, like in VESA KDE mode,
    title Back|Track
    root (hd0,3)
    kernel /boot/vmlinuz vga=0x317 root=/dev/sda4 ro autoexec=kdm

    I also tried to copy the initrd.gz file to the /boot/ directory, and add the " initrd=/boot/initrd.gz" to the Grub config file. (I'm not an old Linux user, I don't realy know, what the initrd does, but just look that: I'm trying! )
    I also tried these options:
    /boot/vmlinuz vga=0x317 root=/dev/sda4 ro autoexec=xconf;kdm
    /boot/vmlinuz vga=0x317 root=/dev/sda4 ro
    My final try was to copy the " /etc/X11/xorg.conf-vesa from the Cd to my sda4/etc/X11/xorg.conf
    Unfortunately, it didn't worked.
    So I would like to ask for your help, becouse I can't solve this problem on my own.
    Thanks for responsing!

    FINALLY I have solved my problem on my own. I'm very proud...
    So, the question is, that why is it runing with the Vesa configurationand why don't run normally?
    That's why i've tried to copy a Vesa conf file, and overwrite the original.
    I have done it through the Live cd..., but didn't worked, but now!!! under the installed Bt3 from HD, it is working.
    So how i solved it:

    just rename the " /dev/X11/xorg.conf-vesa to xorg.conf"
    Remember to make a backup from the original xorg.conf!!

  2. #2
    Just burned his ISO
    Join Date
    Aug 2007

    Default 1800&page=3

    Try that link.
    It will get your drivers installed, but as for getting Catlyast Control Panel to work, im unsure of.
    The instructions of step 3 are written a little poorly, but the steps prior to step 3 will get you booting into Backtrack.
    You just wont have CCP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts