Results 1 to 7 of 7

Thread: Ettercap Problem (Scan For Hosts)

  1. #1

    Arrow Ettercap Problem (Scan For Hosts)

    I'm using Ettercap with Back|Track 3.0 Final (Ettercap-ng 0.7.3), with a NIC (ath0) with an Atheros interface.

    Anyway, I start it up, then:
    • Unified Sniifing (Network interface wifi0)

    Listening on wifi0... (802.11)
    Privileges dropped to UID 0 GID 0...
      28 plugins
      39 protocol dissectors
      53 ports monitored
    7587 mac vendor fingerprint
    1698 tcp OS fingerprint
    2183 known services
    • Scan for hosts

    There's my problem...when I "scan for hosts" nothing happens. It just chills there.

    (My IPtables are uncommented in the config file)

    Any ideas on what the problem/solution could be?

  2. #2


    Problem solved!

    I needed to change my interface to "ath0" instead of "wifi0"

    Hope this helps someone!

  3. #3
    Just burned his ISO
    Join Date
    Jun 2009

    Arrow Ettercap Problem (Scan For Hosts)

    Please, Can you explain how exactly you change interface from wifi to eth0

  4. #4
    Moderator KMDave's Avatar
    Join Date
    Jan 2010


    Quote Originally Posted by moha adel View Post
    Please, Can you explain how exactly you change interface from wifi to eth0
    Read again, ath0 instead of wifi0. And that is by just giving the right option on the commandline
    Tiocfaidh ár lá

  5. #5
    Just burned his ISO
    Join Date
    Oct 2009

    Default Hmm

    Sorry for bumping a old thread but I couldn't get it to work.
    First of all, I'm doing the:
    airodump-ng stop wlan0
    ifconfig wlan0 down
    macchanger --mac 00:11:22:33:44:55 wlan0
    airodump-ng start wlan0
    Then I'll start ettercap and choose my interface, lets say wlan0 but that wouldn't work cause it doesn't accept radio (forgot the word)
    Hmm okey, Ill test mon0 which adds after I had change my mac and reboot the interface but it still wont work.

    Okey, now I have local loopback and wifimaster0 (I think).
    To test some of those I'll have to change my gate-way in the ettercap options to or else it will generate a 16[...] hosts to scan. Then the program locks. After changing the gateway the software still locks.

    So now I wondering, first of all where is the ettercap.conf, i couldn't find it inside usr/local/etc?
    And second, someone with the same problem that have solved it?
    Please, it would be very great full if someone could help.
    Greetings from -Tripfusion-

  6. #6
    Just burned his ISO wookie533's Avatar
    Join Date
    Feb 2010


    I know you may have sorted this by now but the etter.conf is in /etc/etter.conf and you need to remove the 2 # from the lines if you use ip tables under the heading linux and second you dont need to put your wireless card into monitor mode with airmon-ng the only reason im adding this to a post a few months ago is because all over this forum i see how do i get ettercap to do this and i hope this stops more not needed threads in the future, and one thing ive learnt about this forum is its not a classroom its designed to help you help yourself ive never posted a question on here simply because i know that if i do it would have allready been asked and answered if i search hard enough and i dont want to waste the administrators time and look a complete newbie even though i am.

  7. #7
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.


    But how exactly do you change the card to listen to in ettercap text mode ?
    My ettercap default listens to eth0 and I need to change it to wlan0 how do I do that ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts