I just wanted to share my experience getting this to work. I'm a newbie, and I had tried to get MacOSX, WindowsXP, and BT3b triple boot to work, but I decided running XP as a virtual machine on Parallels or VMWare was good enough so I decided on triple boot with Ubuntu. It took a little digging around to get this right so I thought I share it here. Please remember YMMV.

My system description is MacBook Pro 2.33 GHz, 3Gig RAM (upgraded), 200Gig HD (upgraded). Still running OSX 10.4.11.

First, please back up your drive as a "clone" bootable copy! This helps in two ways - you have a safety net in case you mess up your drive. Also, when you're trying to create partitions for Ubuntu/BT3 installation, I feel it takes too long to deframent the internal drive. I find it easier to clone everything to an external firewire drive, boot from the firewire drive, erase and reformat the internal drive, and clone the contents of the external drive back to the internal drive. You wind up with defragmented copy of what was on your internal drive. You also have a complete, bootable back up copy of your drive. (I used Prosoft's Data Backup)

Once you have your drive defragmented, download refit from their site at sourceforge and install. Nothing unusual here.

Next, go to your utilities folder and use your BootCamp Assistant to create a partition for you to use. I used 32Gigs so I can divide it to 16Gigs for Ubuntu and 16Gigs for BT3. Just make the partition, but quit when the Assistant asks you if you want to install Windows. If you are using 10.4 still, BootCamp Assistant will not work since it's "expired". Just manually change the year on your Mac to 2007, and it should work fine.

The following installation starts with BT3. I've tried starting with Ubuntu, but for some reason, I think because of the way Grub, lilo, and refit interact, that just doesn't work so please start with BT3.

Insert BT3 disc, then shut down your Mac. Turn it on again while holding the "c" key or "option" key and choose the BT3 disc. Once Mac starts to boot off of the disc you should see the boot menu. Choose vesa mode. Once it's done booting you should see the log in screen. Log in with "root" and "toor". Once at command prompt type "startx" and you'll be taken to the GUI desktop.

The basic installation of BT3-
delete BootCamp partition, sda3, and create 2 smaller partitions, sda3 and sda4. (this should be covered somewhere else.) Remember to size it so that sda3 is BT3 and sda4 is Ubuntu. Also, I had problems with fdisk complaining that changes could not be written to hard disk because it was busy. In that case try,
umount /dev/sda3
umount /dev/sda4

then try go back to fdisk, don't change anything but just enter "w" and see if it works.
mkfs.ext3 /dev/sda3
mkdir /mnt/bt3 && mount /dev/sda3 /mnt/bt3

Now open the BT3 installer from the menu.
Leave the source blank.
Install to /mnt/bt3
Write new MBR to /dev/sda3
Real installation. Untick Restore Original MBR.
Hit Install.
After it's done reboot.

When you reboot, you should be taken to the refit boot menu automatically. It not, you might be booted into MacOS. If this happens, let it finish booting, then reboot again.

You should now see MacOS and Penguin icons on the boot menu. You may, however, see a Windows icon. In either case, try booting. If it boots into BT3, you're done with BT3 part. However, in my experience, it always gave me "no bootable OS" error. In that case, turn off Mac and go back to refit menu. Among the icons on the bottom, there should be an icon that looks like a disk drive, partition inspector. Choose that. Most likely, it will say something is out of sync, and it'll offer to fix it. Choose yes. Once you're back to refit main menu, don't try booting again. Usually doesn't work. Instead, reboot again. This time, you should definitely see a penguin. Boot into it. It should boot into BT3.

Now quit BT3 and reboot from Ubuntu Live CD. Use the live installer. When choosing the installation location, choose manual method. Choose location as /dev/sda4, file system ext3, mount point "/". Go to next page. Installer will complain about lack of swap partition. Ignore. Keep going to the last page of the installer. click on "Advanced" option. It'll give you choices of where to install bootloader. Choose /dev/sda4. Hit install. Once the installation is done, quit, and reboot. Now you should see MacOS and 2 penguins on refit boot menu. First penguin should boot you into BT3 via lilo. Second penguin should boot you into Ubuntu via Grub.

Again, if you reverse the order of installation, partitions used, etc., I don't know if it'll work.

Also if you've noticed, on the Grub startup menu on the Ubuntu side, Backtrack is recognized and listed. However, if you choose it and try to boot BT3 from Grub menu, it will hang. If you really want to use Grub to boot into BT3, first boot into Ubuntu, and open terminal.
sudo nano /boot/grub/menu.lst
you'll get a text file in a text editor and you have to edit it as super user.
At the very bottom of the file, you'll find boot entry for BackTrack.
It'll say "root=current" << this is the culprit. Edit the entry as follows:

title BackTrack
rootnoverify (hd0,2)
kernel /boot/vmlinuz root=/dev/sda3 ro vga = 791

then save.
BackTrack should now boot from Grub as well as lilo.

This install method does not allow for swap space. I didn't want to mess with logical/extended partitions, etc., which might mess with what I was trying to do. (besides, I'm not comfortable dealing with these coming from MacOS.) However, if you really want to have swap, try using swap file. I saw an easy to follow post on Ubuntu forum. Just do search on "swap file".

I hope this helps someone. I'm really enjoying this open source stuff!