Hey, i just registered and can only post here for three days, so here is my problem (already have searched forums and google extensively):

I am using BackTrack2.0 with aircrack-ng-0.9.3 and a Ralink Card with the RT61 chipset/drivers.

I have cracked plenty of WEPs with this identical setup, they are easy. So I decided to try some WPA-PSK networks.

Everything goes to plan, put card in monitor mode, start airodump-ng on the BSSID / Channel I want, and then start hitting its client with some deauth attacks.

The problem is, even though I have an approx 80% signal strength, deauth has no effect and no handshakes are ever captured.

I have tried just sending one deauth packet, and letting it send them over and over for an hour. Nothing.
See screenshots:

I have tried this on various WPA-PSK networks with signal strengths ranging from 50%-85% with no luck on the handshake. During some of my searches I read that many people were successful with 30/100 connection strengths, so I am wondering if my card might have something to do with it, although its worked flawlessly until now.