Results 1 to 3 of 3

Thread: d-link DWL-G630

  1. #1
    Just burned his ISO
    Join Date
    Jul 2008

    Default d-link DWL-G630

    Hi guys,

    I kindda hit a wall... My laptop came with the ipw2200 wireless adaptor that doesn't support injections, so i ran to the store and bought myself a DWL-G630, the thing is that it seems to be able to inject sometimes...

    usually this is what i get:
    bt ~ # aireplay-ng -9 wlan0
    22:25:05 Trying broadcast probe requests...
    22:25:07 No Answer...
    22:25:07 Found 1 AP

    22:25:07 Trying directed probe requests...
    22:25:07 00:A0:C1:F13:B6 - channel: 6 - 'Credo'
    22:25:13 0/30: 0%

    i get the same result when i use the -a 00:A0:C1:F13:B6 option

    if i play around with airmon-ng, start and stop it a few times then sometimes aireplay works fine... instead of "no answer" it tells me that injection works.

    i was wondering if any of you guys might be able to point me in the right direction. any advice will be very much appreciated!

    thanks a million guys!

    oh I almost forgot...
    I'm running bt3 on a 4gb memstick <--- thats what i'm currently using
    i have bt2 installed on my HD, but I rarely use it.
    Wireless card: D-link g-630

  2. #2
    Join Date
    Mar 2007


    I would have replaced the internal card with this:

    If your messing about with your own stuff then its really all you need. It works with the mad-wifi drivers in BT3 great, you'll see alot of the tutorials here are demonstrated using same or similar chipsets.

    Have you checked to make sure your using the right device the zydas in my laptop didn't support injection but would still show up in config.

    Just looked at the wiki and it claims to use atheros chipset so you should be using madwifi drivers, in which case if your trying to crack wep this guide could be followed almost exactly:
    Don't discount Windows, I would be a poor man without it ;)

  3. #3
    Just burned his ISO
    Join Date
    Jul 2008


    Hi Johnyt,

    Thanks for your quick response i'll check my local stores for that wifi card u posted a link to. Do you know if there is a USB or PCMCIA version of the same product, or something simmilar? That would make it easier for me to install.

    i'm positive that i am using the right device, I rmmodded the ipw2200 so the only one left is the rt61 wlan0.

    it turns out that if i do this:
    ifconfig wlan0 down
    rmmod rt61
    modprobe rt61
    airmon-ng start wlan0
    aireplay-ng -9 wlan0

    then it seems to be working 60% if the time... as long as i do not change the monitoring channel...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts