Results 1 to 5 of 5

Thread: Can't connect to the inetrnet in bt4

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010

    Default Can't connect to the inetrnet in bt4

    I run various linux distros from DVD drive as iso images. I have new Fedora 12 in hard drive C:.
    Here is my problem : I can't connect to the internet with ANY distro EXCEPT with BT 3 and PC-BSD. Backtrack Linux 3 and PC-BSD 8 work great out of the box and no other linux distro works including new BT 4.
    My computer is HP Compaq laptop CoreDuo @ 1.73 with 2 GB of RAM. My ISP is BellSouth and they do not want to cooperate even if I want to pay their advance technical support (they do not want to support anything except windows and mac). The only modem I can use with BellSouth is supplied by them and is Motorola Netopia DSL (nothing else works I tried it).
    In BT 3, PCBSD and windows I access modem by typing in my browser and if I can do that in BT 4 I would not have Internet problem but in BT 4 and all other distros when I try to do it I get message Can't connect to server.
    I know that BT 4 switched to Debian hence my internet problem. How does BT 4 handle IP connection differently?
    I suspect problem is with eth0 - when I type ifup eth0 i get can't assign address and if I try to access modem by typing it gives me can't access server.
    route -n gives me following Destination 127.0.0 Gateway Genmask
    if config gives me just >
    Here is output from BT3 where my connection works (by typing in browser):
    Route Preferences
    Address Netmask Name Ethernet 100BT WAN VCC1
    Network Routing Table
    Destination Netmask Gateway Interface Metric RIP WAN cc1 0 N/A Ethernet 0 N/a
    Host Routing table
    Destination Netmask Gateway Interface Metric RIP Loopback 0 N/A WAN 0 N/A Ethernet 0 N/A
    Home Summary Offline Ethernet Active Ethernet
    Broadband DSL line
    WAN IP Address
    Gateway IP Address

    DHCP Server IP

    DHCP Server IP

    As far as I noticed all values are static except for WAN.
    I was told by BellSouth that my address was dynamic.

    I tried without any results to set IP manually by setting my IP address and gateway or
    with netmask or
    What to do to get internet connection?
    Thanks a lot in advance for all persons sending reply and trying to help me.

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010

    Default Re: Can't connect to the inetrnet in bt4

    I dont see any reference to this HowTo mentioned in your post. Did you follow it when trying to setup your network?
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  3. #3
    Just burned his ISO 213374U's Avatar
    Join Date
    Mar 2010


    Run this in Terminal:

    [CODE]/etc/init.d/networking start/CODE]

    Try running this in Terminal:

     /etc/init.d/networking start
    Last edited by Archangel-Amael; 03-31-2010 at 09:35 PM.

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: Can't connect to the inetrnet in bt4

    Or try starting the wicd manager from BT4 and than open it to check for any available connections
    /etc/init.d/wicd start

  5. #5
    Join Date
    Feb 2010

    Default Re: Can't connect to the inetrnet in bt4

    after ,,ifup eth0,, did you also run ,,dhclient eth0,, ?

Similar Threads

  1. How do i connect to 802.1x in BT?
    By bQnne in forum Beginners Forum
    Replies: 5
    Last Post: 03-17-2010, 02:19 AM
  2. How to connect to cracked WEP
    By garmada in forum Beginners Forum
    Replies: 3
    Last Post: 03-04-2010, 03:04 PM
  3. CACAn not connect to wpa
    By rjmjr69 in forum Beginners Forum
    Replies: 1
    Last Post: 03-04-2010, 09:14 AM
  4. Connect to Internet
    By aamir99 in forum Beginners Forum
    Replies: 2
    Last Post: 02-11-2010, 08:57 PM
  5. Can't connect to wifi
    By doligal in forum Beginners Forum
    Replies: 5
    Last Post: 02-10-2010, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts