Results 1 to 3 of 3

Thread: Problem running Airodump on Ubuntu...

  1. #1
    Just burned his ISO
    Join Date
    May 2008

    Default Problem running Airodump on Ubuntu...

    I know this is mostly a Backtrack forum, but Backtrack has now taught me to use Airodump and Linux, so I'm trying to install Ubuntu and use it from there...

    I have an Atheros wifi card on a Thinkpad T40, and Backtrack works perfectly on this laptop from the live CD. I just installed Ubuntu 8.04 to the harddrive and installed the necessary software with these commands:

    sudo apt-get install aircrack-ng
    sudo apt-get install madwifi-tools

    I then stop my Atheros card like this, which works:

    sudo airmon-ng stop ath0

    I then start it using the Mad Wifi drivers like this:

    sudo airmon-ng start wifi0

    Now when I run iwconfig, it reports the card as ath0 in monitor mode, so far so good....

    However, when I run Airodump my card never sees any networks:

    sudo airodump-ng --write capturefile ath0

    It scans through the channels, but never sees any networks. Adding the --ivs switch doesn't help.

    I know there are networks, and when I repeat these commands from Backtrack with the laptop in the same location, I see plenty of networks. And Ubuntu connects to networks with this wifi card before I load the Madwifi drivers.

    Any tips?

  2. #2
    Join Date
    Mar 2007


    sounds simple, but did you try #ifconfig ath0 up?

    also, is your wifi card turned on, maybe there is a hardware switch to enable the device? bios setting perhaps?

    I just tested your commands on heron Ubuntu and they work fine on my atheros card. try my above suggestions.
    the output of my #lspci shows
     02:03.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
    as my atheros card.

  3. #3
    Developer balding_parrot's Avatar
    Join Date
    May 2007


    Quote Originally Posted by luthertrowe View Post
    I know this is mostly a Backtrack forum,<snip>
    Any tips?
    No, it is a Forum for the support of the BackTrack OS.

    If you want support for Ubuntu, go to their forums or the aircrack forums as this is related to aircrack on Ubuntu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts