I know this is mostly a Backtrack forum, but Backtrack has now taught me to use Airodump and Linux, so I'm trying to install Ubuntu and use it from there...

I have an Atheros wifi card on a Thinkpad T40, and Backtrack works perfectly on this laptop from the live CD. I just installed Ubuntu 8.04 to the harddrive and installed the necessary software with these commands:

sudo apt-get install aircrack-ng
sudo apt-get install madwifi-tools

I then stop my Atheros card like this, which works:

sudo airmon-ng stop ath0

I then start it using the Mad Wifi drivers like this:

sudo airmon-ng start wifi0

Now when I run iwconfig, it reports the card as ath0 in monitor mode, so far so good....

However, when I run Airodump my card never sees any networks:

sudo airodump-ng --write capturefile ath0

It scans through the channels, but never sees any networks. Adding the --ivs switch doesn't help.

I know there are networks, and when I repeat these commands from Backtrack with the laptop in the same location, I see plenty of networks. And Ubuntu connects to networks with this wifi card before I load the Madwifi drivers.

Any tips?