Hi im new to linux in common and im tryng not to ask any noob questions which have already been answered a thousand time. So after my issues I started reading and searching but I just cant find a solution. So I decided to post here.

After trying BT3 live usb I was looking forward to installing BT4. In bt3 live usb internet worked fine.

I have a Toshiba A300 12k with built in eth0 and a wlan0(rtl8187b)
I also purchased a usb wifi adapter which is a rtl8187L.

Once again, in bt3 live usb they worked fine.

After installing BT4 internet did not work so I looked at System settings>internet>Network interfaces>

There were none ( except lo )

So I looked around and tried the How To start networking but also this did not work.

I only care about the usb adapter.

I edited the interfaces file to:





of course with all the stuff around it.

If anyone could please help me...

When entering the commands from the How To
Every interface ends with

No working leases in persistent database - sleeping