Results 1 to 2 of 2

Thread: USB stick with changes; X not starting after driver update

  1. #1
    Just burned his ISO
    Join Date
    Oct 2006

    Default USB stick with changes; X not starting after driver update

    First off, I'm gonna be typing this by hand as i'm not very familiar with command line, and am not sure how to copy/paste my xorg.conf here in text mode...

    I have a Radeon 9550 in a desktop pc. Using balding parrot's tut for live w/changes, I had a working BT3 distro, but of course compiz wasn't working (and who doesn't want compiz?). So I went to the wiki and followed the link to the compiz site and found the latest driver for my card


    I downloaded the fglrx driver and everything seemed to go alright. shut down and restarted compiz-fusion with no change, so i rebooted. I have been booting the compiz version of bt3, without startx in the boot options, then running xconf at prompt, followed by startx which has worked fine until now.

    On reboot, X failed to initialize:

    "(WW) fglrx: No matching Device section for instance (BusID PCI:2:0:1) found
    (EE) fglrx(0): Given depth (8) is not supported by fglrx driver
    (EE) fglrx(0): PreInitVisual failed
    SetVBEMode failed
    (EE) fglrx(0): PreInit failed
    (EE) Screen(s) found, but none have a usable configuration

    Fatal server error:
    no screens found
    giving up."

    At this point I haven't done anything to my xorg.conf (that I'm aware of). Here's what it looks like:

    "#nano /etc/X11/xorg.conf

    Section "ServerLayout"
    Identifier " Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"

    Section "Files"
    RgbPath "/usr/share/X11/rgb"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/TTF"
    FontPath "/usr/share/fonts/OTF"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/misc"
    Fontpath "/usr/share/fonts/75dpi/:unscaled"

    Section "Module"
    Load "GLcore"
    Load "dbe"
    Load "dri"
    Load "extmod"
    Load "glx"
    Load "record"
    Load "xtrap"
    Load "freetype"
    Load "type1"

    ***i'll skip input devices***

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"

    Section "Device"
    Identifier "Card0"
    Driver "fglrx"
    VendorName "ATI Technologies Inc"
    BoardName "RV350 AP [Radeon 9600]"
    BusID "PCI:2:0:0"

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    SubSection "Display"
    Viewport 0 0
    Depth 1

    ***repeat subsection for depths 4, 8, 15, 16, and 24***.

    lspci says that:

    "02:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
    02:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)"

    glxinfo gives me an error: unable to open display

    Can someone familiar with radeons and compiz please help me?? Thanks!!

    ps: sincerest apologies again for all the text!

    have also tried booting into kde without compiz, same issues

  2. #2
    Senior Member
    Join Date
    Feb 2008


    you should ask at the compiz forums...
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts