Results 1 to 2 of 2

Thread: Broadcom 4312 and Marvell 88E8040 Not Working on HP Mini 1030NR

  1. #1
    Just burned his ISO
    Join Date
    Jan 2009

    Question Broadcom 4312 and Marvell 88E8040 Not Working on HP Mini 1030NR

    I have an HP Mini 1030NR (1000 series) with BT3 running on USB. Neither wired nor wireless networks are showing anything. lspci shows

    01:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)
    02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

    ifconfig and iwconfig only show lo. Am I not doing something I'm supposed to? I tried
    #locate bcm43xx
    and several things came up, including firmware files, drivers, and a patch for aircrack-ng entitled bcm43xx-injection-linux-2.6.20.patch

    Is there any way I can get this to work? The wireless is the mroe important function but right now I'm not getting any internet or otherwise even plugged into my home wired network. I've tried to find stuff relevant to my problem but haven't, if this is posted elsewhere, please direct me there. Thanks.

  2. #2
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    在這兩者之間 BackTrack是4 FwdTrack4


    This topic has been covered 1000 time and you are saying you could not find any similar post.I would like to recommend you to find the forum honestly and that broadcom piece of shit don't work with the kernel supplied with bt3.if you want to use then upgrade kernel to at least 2.6.24 or above.then you need to patch the kernel with modified b43 drivers.very hectic job as its needed for correctly functioning newer hardware device.find a post of dr. green for upgrading to the latest kernel & recompiling the kernel with ext4 is what you need to patch to kernel for discovery/injection support for bcm43xx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts