Ok, so I am trying an AP with no clients. I have searched for quite some time, and read lots of tutorials from many sites and none of my research has seemed to fix my issue. I try to associate myself to the AP but it just *ignores* my requests. I know I can reach the AP because I was getting deauth packets for a while on another test, so my packaets can reach the router for sure. The commands I am using to associate are:

aireplay-ng -1 0 -e apname -a apmac -h mymac eth0

aireplay-ng -1 6000 -o 1 -q 10 -e apname -a apmac -h mymac eth0
which yields me

Sending authentication request

over and over until it finally gives me a nice paragraph about why its potentially not working. I have tried lowering my txrate to 2M and 1M. Locked my device to the AP channel. I have tried starting airmon before, after, during the tests, ive tried various attacks HOPING that it would just magically work (which it of course did not). In the end, its all because I have a failure to associate and cannot understand why. Before you flame me, plsd to know that I am on a budget and cannot afford any decent hardware atm, so im kinda stuck with a piece of crap broadcom. :s

System specs

hp dv6000 laptop with broadcom 4311
bt2 final live cd

I hope I have been detailed enough.