Results 1 to 2 of 2

Thread: *Fixed* If you alfa card disconnects after awhile and keyboard fails

  1. #1
    Junior Member
    Join Date
    May 2007

    Default *Fixed* If you alfa card disconnects after awhile and keyboard fails

    OK where do i start!!! I've been using BT3 for while and when i brought my ALFA card for my Samsung R60+ laptop i thought it was the best thing since i lost my virginity! And after a connected to the net and grabbing files off torrent my alfa card would disconnect and this would make it impossible for me to even use my keyboard 'SERIOUSLY' i couldn't type unless i remove my card. When i reinserted my card i couldn't even scan for AP's :-(. So i thought maybe its summat do with my Alfa card! I tried my brothers ALFA card and still i had the same problem! So i thought...MMMMMMMMM Maybe it was my drivers! Tried reinstalling them and still ad the same problem. So i thought could my USB controller be have some sort of my conflict with the driver! So i downloaded the latest kernel use the configuration from the BT3 kernel.lzm. Compiled it using make, make_install, make_modules Blah blah blah. Rebooted then installed the rtl8187 driver from aircrack also i applied the patch with was about 400k. patched it. Installed the driver, rebooted and BANG it worked. I've been online for about 4 hours and it hasn't cut off, plus my laptop starts up quicker :-D, and my keyboard is FINE :-D. I hope this helps people. Heres the link for the driver and patch and kernel.

    Kernel -

    RTL8187 Patch-

    I hope this helps people with the whole problem of you keyboard dying, and your card disconnecting after awhile
    Alot of people ent ad this problem so i'm thinking as we dont all av the same laptops etc etc etc, then maybe it's to do with the USB driver. After i installed the kernel my transfer rate from my USB memory stick has improved so much!

  2. #2
    Join Date
    Jan 2007


    The drivers for rtl8187 are included in There's no reason to download older drivers and patch them. Injection with the stock driver works flawlessly on my gentoo system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts