Results 1 to 3 of 3

Thread: upgrading the kernel

  1. #1
    Join Date
    Feb 2007


    Hello all, so following the instructions in i have upgraded my kernel (see last post in that thread).

    Having tried and 2.6.28-rc6 i keep running into the same thing: my new hardware is detected, but trying to configure things like the nvidia driver ends badly. The logfiles claim that linux configuration files are missing, etc etc... evil stuff. Is there something to be done post-config to fix this?

    I'm also unable run the diff patches for the ilwlan drivers which would allow me to use monitor mode and injection, i keep getting errors:
    bt linux # patch -p1 --verbose < patch_iwl-agn
    Hmm... Looks like a unified diff to me...
    The text leading up to this was:
    |diff --git a/drivers/net/wireless/iwlwifi/iwl-agn.c b/drivers/net/wireless/iwlwifi/iwl-agn.c
    |index c3b1789..1547122 100644 (file)
    |--- a/drivers/net/wireless/iwlwifi/iwl-agn.c
    |+++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
    Patching file drivers/net/wireless/iwlwifi/iwl-agn.c using Plan A...
    patch unexpectedly ends in middle of line
    Hunk #1 FAILED at 2730.
    1 out of 1 hunk FAILED -- saving rejects to file drivers/net/wireless/iwlwifi/iwl-agn.c.rej
    I'm guessing that the patch was made for an earlier driver, but this happens with with as well as 2.6.28-rc6. I'm lost... can anyone help? Thanks

    So this is what the nvidia installer log shows with kernel 2.6.28-rc6:
    -> No precompiled kernel interface was found to match your kernel; would you li
    ke the installer to attempt to download a kernel interface for your kernel f
    rom the NVIDIA ftp site ( (Answer: Yes)
    -> No matching precompiled kernel interface was found on the NVIDIA ftp site;
    this means that the installer will need to compile a kernel interface for
    your kernel.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    -> Kernel source path: '/lib/modules/2.6.28-rc6/source'
    -> Kernel output path: '/lib/modules/2.6.28-rc6/build'
    ERROR: If you are using a Linux 2.4 kernel, please make sure
    you either have configured kernel sources matching your
    kernel or the correct set of kernel headers installed
    on your system.
    /lib/modules/2.6.28-rc6/source and build both point to /usr/src/linux which points to /usr/src/linux-2.6.28-rc6... thats the directory i was in when i compiled and installed the kernel, so i figure kernel sources are where they're supposed to be. What about headers? I'm actually a bit confused as to what kernel headers are, how to view the setup, or what the correct setup even is. F my life *sigh*.

    On the bright side, this might be the first kernel build done by a grunt in iraq . This place is so out of whack i'm actually enthused to watch a kernel build itself on my day off.

  2. #2
    Join Date
    Mar 2007


    Allright so like I said you should tackel one issue at a time. So the nvidia one should be pretty simple. You need to make sure you remove the old module and reload it after the new kernel build. for example.....
    purehate@pwnsauce ~ $ lsmod
    Module                  Size  Used by
    vmnet                  29472  15 
    vmmon                1826028  7 
    snd_seq                52336  0 
    snd_seq_device         10900  1 snd_seq
    snd_pcm_oss            40480  0 
    snd_mixer_oss          18560  2 snd_pcm_oss
    nvidia               7790112  68 
    snd_hda_intel         397636  4 
    snd_pcm                74120  3 snd_pcm_oss,snd_hda_intel
    snd_timer              24080  3 snd_seq,snd_pcm
    snd                    54904  11 snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer
    snd_page_alloc         12304  2 snd_hda_intel,snd_pcm
    That shows its loaded so now build your kernel and reboot...

    Whenyou get in the frame buffer unload the old module and load the new one
    purehate@pwnsauce ~ $ sudo modprobe -r nvidia
    purehate@pwnsauce ~ $ sudo modprobe nvidia
    Now try to buil the nvidia driver against the new module and then try to startx

  3. #3
    Join Date
    Feb 2007


    I've been building it with the nvidia module inserted all along, hmm. Soon as it's done i'll reboot into the new build and see if it's still loaded and try to build again. Net connection here is slow... gotta go to the civ contractors and download the new 177 nvidia driver (using 169) while this is building.

    I know its early morning there, and you're probably tired, but is there any chance you could give me a bit of insight as to what you think is happening? So long as i'm being spoonfed i might as well learn .

    Which brings me to another question - does it make sense to try and pull the ilwifi drivers from the kernel release that the injection patches were made for? I cant seem to get the new ones patched and since everything operates on a binary/hex level with diff any offset would likely cause this mess. yet again, i'm running into the net connection problem (getting the kernel source for 2.6.27, and the diff to upgrade 2.6.27 to 2.6.28-rc6 took days), so if i am to try and do this, does anyone have a copy of that kernel tree handy so i could possibly swipe a compressed copy of the intel driver dir itself?

    Thanks pureh@te, your help is greatly appreciated (even though you're probably wretching from the spoonfeeding process ). I honestly think i'm losing vast numbers of brain cells out here, soon i wont be able to distinguish a keyboard from a hot dog.

    came across something interesting while reading online regarding this issue:

    Quick note: If you want to use Linux 2.6.28 and the NVIDIA 177.80 driver, you must:
    cd /lib/modules/$(uname -r)/source/include/asm-x86
    cp -r ../../arch/x86/include/asm/* .
    looks like the powers that be are doing some restructuring in where headers are stored... i'll have to try that soon as my current compile cycle is done (adding some wireless support for other cards, still trying to figure out the 5100 injection problem though)

    Looks like i've got it almost completely figured out. I'm now running kernel, with intel IHC9 sound working perfectly well, the newest nVidia driver installed, and using my 5100AGN wlan adapter (albeit i still can't patch the bloody drivers).

    After my abysmal failure with 2.6.28-rc6 i cleaned up, configured, and compiled It seems .28 was compiling in ia64 mode for some reason - there were no x86 headers, which isn't an issue with .27.7. I'm a bit too tired to go about testing all of BTs features, but i tried to configure the kernel to be as flexible as possible with wide ranging hardware and network support. Next i need to figure out how to add injection patches, at least for my own wireless drivers, then see if i can't get this kernel working with the lzm structure on the USB install.

    So yeah, if people are having problems using the new core2duo/centrino2 hardware this kernel seems to support it all just fine. If you do get it running, remember to run alsaconfig to get the sound up.

    Pureh@te, thanks for all the help. Happen to know anything about patching these drivers? I'm making a new post regarding this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts