Results 1 to 3 of 3

Thread: Another N00b with an AirSnarf toubles

  1. #1
    Just burned his ISO prozac88's Avatar
    Join Date
    Apr 2008

    Default Another N00b with an AirSnarf toubles

    Hello to you all, I know someones gonna slam me for it as there are alot of threads on here about AirSnarf (i kno, i read them all) however I think I am safe to say that for some people they jsut arent working 100%. I am running Windows Vista with a AR5007EG card with VmWare BT3F and Netgear WG111Tv2.

    Now I follow guides to the T before asking for any help and here I am asking for help.

    Ive followed the following steps in the wiki:
    1.1 1. Open Kwrite and Copy/Paste
    1.2 2. Open Kwrite and Copy/Paste
    1.3 3. Alter permissions and create folders
    1.4 4. Download dhcp-3.0.*-i486-2.tgz
    1.5 5. Move the dhcp file to /
    1.6 6. Change directory and edit airsnarf
    1.7 7. Edit airsnarf.cfg
    1.8 8. Edit dhcpd.src
    1.9 9. Edit
    1.10 10. Copy/Paste index.html & airsnarf.jpg

    I have an issue with 1.4 4. Download dhcp-3.0.*-i486-2.tgz as i cant find the file to download.

    I run apache, i run airsnarf, at i get the login window.

    Ive tried

    echo 1 > /proc/sys/net/ipv4/ip_forwardConfig ad hoc:

    iwconfig wlan0 essid YOURLAN mode ad-hoc


    iwconfig wlan0 key "S0m3p/\s$"Set device IP and netmask:

    ifconfig wlan0 192.x.x.x netmask up

    and still no luck.

    As it stands I have airsarf telling me its waiting for connections however I cant see the connection on any computer.


  2. #2
    Just burned his ISO prozac88's Avatar
    Join Date
    Apr 2008


    after doing my head in over this airsnarf thing for a week i am still stuck. when i run airsnarf i get the errors:

    Creating dhcpd.conf...Done.
    Building the captive portal...Done.

    Setting the wireless parameters...wlanconfig: ioctl: Operation not supported

    wlanconfig: ioctl: No such device

    Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device eth0 ; Operation not supported.

    i am using a wg111 v2 or i can use a zd1121rw.
    from what i can gather i need to set a ath0 or a wifi0, but when i use iwconfig ath0 mode Master i get "wlanconfig: ioctl: No such device" back.

    does anyone kno how to set these devices to the correct mode.

    thank you

  3. #3
    Senior Member
    Join Date
    Jun 2007


    I am also stuck with airsnarf so this may be the blind leading the blind
    try this before running airsnarf

    wlanconfig ath0 destroy
    wlanconfig ath0 create wlandev wifi0 wlanmode master

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts