Results 1 to 7 of 7

Thread: Ettercap usage over wireless network

  1. #1
    Just burned his ISO
    Join Date
    Nov 2006

    Default Ettercap usage over wireless network

    I know this question has probably been asked a lot of times, and I've seen that they weren't asnwered =/ but anyway here's my situation.

    I watched videos on youtube of how to use ettercap and stuff and also yeehaw's sniffing tutorial of how to enable SSL dissection. I followed both word for word. But i realize that ettercap doesn't capture any passwords over my wireless network -- i tried logging in myspace and yahoo but niether were captured =/ I tried looking this problem up on ettercap forums but it said sumthing like ettercap doesn't work when the network card is in monitor mode or sumthing =/

    Im using BT2 final and ipw3945 card =/

    any ideas any1?

    ps: yea i enable ARP poisoning

  2. #2


    You have to be connected to the network with an IP for ettercap to work. Read up on ARP poisoning and you will have a better idea of how ettercap works.

  3. #3
    Member imported_anubis2k7's Avatar
    Join Date
    Jun 2006


    as 'nder84 stated, you have to be connected to the network. Also, DHCP has to be enabled on the wireless router (in other words, you should get a 192.168 or other private address) This enables you to "impersonate" the default gateway.
    "Sure is for people with nothing on the and me? We just get on with it."


  4. #4
    Junior Member drwalter's Avatar
    Join Date
    Mar 2008


    Double check your hosts after scanning. make sure you set the gateway for target 1 and the victim(s) for target two that should disambiguate any problems after turning sniffing on.
    ================================================== ===
    Dr. Walter - Depraved linguist, Benevolent troublemaker extraordinaire
    ================================================== ===

  5. #5


    doublecheck with etherreal or wireshark to make sure that this is a ettercap issue or not

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010

    Default this worked for me

    go to your etter.conf and uncomment the 2 lines under "if you use iptables".
    this video shows how *
    I hope this helps, at least this worked for me.

  7. #7
    Just burned his ISO
    Join Date
    Nov 2009


    digging up old threads i do that by mistake every so often. click here click there next thing you know you have traveled 2 years into the past. who said time traval is not a reality....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts