Results 1 to 3 of 3

Thread: Wireshark & Monitor Mode (AWUS036H) trouble

  1. #1
    Just burned his ISO
    Join Date
    Sep 2011

    Default Wireshark & Monitor Mode (AWUS036H) trouble

    I've installed Backtrack 5R1 and i have a trouble to get the monitor mode working in Wireshark.
    I connect the card and start monitor mode via airmon-ng. Then I' start the Wireshark and select the mon0 interface. But the checkbox for Enabling monitor mode is grey. I'm using the AWUS036H card with RTL8187 chipset.
    Is there some trick to enable the monitor mode in Wireshark.
    Now I'm using the clean install of Backtrack R5.
    I've had the same issue with Backtrack 4. I've tried to compile new version of Wireshark from SVN, with newest libpcap. But without any success.

  2. #2
    Good friend of the forums scottm99's Avatar
    Join Date
    Feb 2010

    Default Re: Wireshark & Monitor Mode (AWUS036H) trouble

    Have you tried other wireless tools (e.g. Kismet, airodump-ng, etc) to see how they work? Also, have you tried just plugging your card in & turning on monitor mode from within Wireshark (skipping the airmon-ng step)?

    I'm not a Wireshark pro, but I prefer to do my packet capture using something other than Wireshark, then load the pcapdump files into Wireshark for analysis.
    If I could figure out how to scuba dive & hack at the same time, there would be nothing I couldn't do...

  3. #3
    Senior Member
    Join Date
    Jan 2010

    Default Re: Wireshark & Monitor Mode (AWUS036H) trouble

    Quote Originally Posted by scottm99 View Post
    Also, have you tried just plugging your card in & turning on monitor mode from within Wireshark (skipping the airmon-ng step)?
    you may not be a "wireshark pro" as you posted, but you are absolutely correct as this is not actually wireshark specific. allowing airmon-ng (or any other process) to put the card into monitor mode, will not allow another process to use the same wireless interface in monitor mode at the same time. the interface is greyed within wireshark; because the interface is already in use by the other process which was loaded first.

Similar Threads

  1. Replies: 10
    Last Post: 01-24-2011, 01:58 AM
  2. Alfa 500mw monitor mode > managed mode
    By jpm11 in forum OLD Newbie Area
    Replies: 0
    Last Post: 02-25-2009, 10:20 AM
  3. Wireshark: WLAN must be in Managed or Monitor mode?
    By lanwarrior in forum OLD BT3beta
    Replies: 4
    Last Post: 12-12-2008, 04:01 AM
  4. Replies: 6
    Last Post: 10-09-2007, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts