Results 1 to 2 of 2

Thread: Wireless doesn't work after apt-get upgrade

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010

    Default Wireless doesn't work after apt-get upgrade

    I'm using Intel wireless 3945abg. It used to work perfectly until I did some upgrades yesterday.

    I upgraded using Synaptics Package Manager>Marked all upgradeables>Apply.
    I'm not sure what caused the problem, but one of the upgrades was this madwifi-drivers. Could this be the cause of the problem?

    In wicd, it just says there are 'no wireless networks detected.'

    wlan0 is not visible when i typed ifconfig in the console.
    but it's listed when ifconfig -a is typed.

    When i typed 'ifconfig wlan0 up'
    i get this error message

    SIOCSIFFLAGS: No such file or directory

    typing these
    modprobe -r iwl3945
    modprobe iwl3945

    doesn't help either.

    in dmesg, there are these error messages.
    iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
    iwl3945 0000:0c:00.0: iwlwifi-3945-2.ucode firmware file req failed: -2
    iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-1.ucode
    iwl3945 0000:0c:00.0: iwlwifi-3945-1.ucode firmware file req failed: -2
    iwl3945 0000:0c:00.0: Could not read microcode: -2

    I tried installing firmware-iwlwifi, but still get the same error message
    Tried reverting back to kernel, but the same error persists

    I'm not really good with linux and I'm totally clueless about the cause of the problem.
    How do I rectify the problem?

    I've googled and searched the forum, but things that i got don't seem to fix the problem..

    Any help is greatly appreciated.....

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010

    Default Re: Wireless doesn't work after apt-get upgrade

    Take a look at the following post:

Similar Threads

  1. Intel Pro 3945abg doesn't work work after apt-get dist-upgrade
    By PalmerEldritch in forum BackTrack Bugs
    Replies: 2
    Last Post: 07-22-2010, 02:02 PM
  2. Replies: 0
    Last Post: 11-17-2009, 09:08 PM
  3. My wireless doesn't work
    By thugz_life in forum OLD Bt4beta Non-Working Hardware
    Replies: 1
    Last Post: 06-22-2009, 10:27 AM
  4. BT3 + Wireless Network doesn't work
    By kenchi in forum OLD BT3beta General
    Replies: 7
    Last Post: 12-19-2007, 11:40 PM
  5. Replies: 2
    Last Post: 05-14-2007, 05:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts