Results 1 to 6 of 6

Thread: Backtrack Atheros,Attansic and Acer Fix

  1. #1
    Just burned his ISO dre360's Avatar
    Join Date
    Jan 2010

    Default Backtrack Atheros,Attansic and Acer Fix

    Hi all, Over the past week I have been using my friend goole to fix my acer aspire 5517 LAN and WIFI problem and found somethings that would help other people fix there problems as well.
    Please note this is not just for acer this is for the Atheros Communications Inc WiFi & Attansic Technology Corp LAN

    1: My wifi and lan are listed bellow

    dre360@haktop:~# lspci

    Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    08:00.0 Ethernet controller: Attansic Technology Corp. Device 1062 (rev c0)

    Out off the box backtrack 4 won't work well with atheros Wifi card and Attansic Lan.

    2: If I type ifocnfig I get

    dre360@haktop ifconfig

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:247 errors:0 dropped:0 overruns:0 frame:0
    TX packets:247 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:121377 (121.3 KB) TX bytes:121377 (121.3 KB)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:************ P-t-P:************ Mask:2**************
    RX packets:391 errors:6 dropped:0 overruns:0 frame:0
    TX packets:397 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:94375 (94.3 KB) TX bytes:27925 (27.9 KB)

    and if I type ifconfig eth0 up
    I get errors like 'unable to find eth0 etc...'

    3: install acerhk-source

    Source for the acerhk driver will work with the ACPI-WMI and the kernal to have a peace full please see "h**p:// for more information"
    then reboot. then I dmesg

    4: dre360@haktop:~# dmesg |more

    ACPI: WMI: Mapper loaded
    acer-wmi: Acer Laptop ACPI-WMI Extras

    great the kernal and ACPI-WMI are working hand in hand.

    Onto the wireless
    install the madwifi-drivers
    madwifi-ng drivers including injection patches for kernel then reboot.

    Q 'but how would I know if the madwifi-drivers worked?'
    A when you connect to a AP your signal would be 20,30..80% etc and not 0% as before the madwifi-drivers was installed.

    I tried my best to make this post newbie less as possible.
    Please let Me know if this post helped anyone.

  2. #2
    Just burned his ISO
    Join Date
    Dec 2009

    Default what about reboot on livecd?

    I'm using BT4 via the liveCD, I don't think I can reboot...

    Any way to get the ar5b91 to work without rebooting? Thanks in advance!

  3. #3
    Just burned his ISO
    Join Date
    Dec 2009


    I have Atheros AR5B91 , and backtrack 4 cant find him when i write airmon-ng
    Can you help me where i could find drivers or something like that for fixing ?
    I am running Backtrack 4 on VMWARE.
    Help please

  4. #4
    Senior Member
    Join Date
    Aug 2007


    Shagy: It will never work on vmware

  5. #5
    Just burned his ISO
    Join Date
    Dec 2009


    Which program should i use ?

  6. #6
    Junior Member
    Join Date
    Jan 2010


    Quote Originally Posted by Shaqy View Post
    Which program should i use ?
    the answer you're looking for is right here:
    Aquillar> hey, you guys ever play kmem russian roulette?
    Agnostos> I don't believe I have. care to explain the details?
    Aquillar> dd if=/dev/urandom of=/dev/kmem bs=1 count=1 seek=$RANDOM
    Aquillar> keep executing until system crashes
    Aquillar> person that crashes system has to buy beer
    Agnostos> lol
    Agnostos> I wonder if I can sneak that into a server startup script here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts