Results 1 to 4 of 4

Thread: apt-get upgrade screwed up dhcp

  1. #1
    Junior Member carrot's Avatar
    Join Date
    Nov 2007

    Default apt-get upgrade screwed up dhcp

    I just did an apt-get upgrade on my installation of BT4 Pre-final and now when I boot up, I get the following error:

    Starting DHCP server: dhcpd3* check syslog for diagnostics.
    I looked in /var/log/messages, but I couldn't find anything helpful.

    A little nonsense now and then is relished by the wisest men.
    -Willy Wonka-

  2. #2
    Junior Member
    Join Date
    Jan 2010


    I remember having the same error after upgrading BT4. But I didn't notice any problems with DHCP.

    If you want an address, use: dhcpcd [interface]

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010

    Default The Fix

    Had the same situation, so I searched and found ...

    Bottom of the page reveals a fix to remove the dhcp service trying to start up at boot.

    update-rc.d -f dhcp3-server remove
    There are a number of threads started for this issue, but I thought that since I looked into it today and fixed it... so might as well help

    Search and you shall find?

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010


    It didn't screw anything up. Until you have the setting set up for a dhcp server, it's going to give you that message. Since you think it's broken, you don't need a dhcp server running on your backtrack box. You can either remove it, like the post above, or ignore it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts