Alright, I installed both privoxy and tor into the BT4-pre using apt-get. They both startup fine, no errors. For privoxy I'm using the config file which can be found at torprojects website (which I can't put a link to due to posting restrictions) and I'm using the default torrc. I've installed torbutton on firefox. According to netstat privoxy is listening on localhost:8118, and tor is listening on localhost:9050, as they should be. So I would think everything would work.

But when I go to firefox and turn on the torbutton privoxy can't seem to find tor. It pops up an error message saying: Forwarding failure, Privoxy was unable to socks4a-forward your request <url> through
SOCKS request rejected or failed.

I searched around and the only advice I could get was that it might have to do with my hosts.allow/hosts.deny. I put into my hosts.allow, but still no dice.

I'm running inside of VirtualBox, but I don't think that matters since I've gotten tor working in windows through virtualbox, and because it doesn't seem to be a matter of tor not interacting correctly with it's environment, but with privoxy not finding tor.

Does anyone know what would prevent this from working?

[EDIT]: Tor just started working. I didn't do anything at all, but whatever. Problem solved I guess. Hope it keeps up. Ignore this thread.