Results 1 to 7 of 7

Thread: Asus eee 901-1000x rt2x00

  1. #1
    Just burned his ISO
    Join Date
    Feb 2009

    Arrow Asus eee 901-1000x rt2x00

    I know the popular Asus eee PC, models "901-1000x" contain a Ralink chipset that never fully worked in BT3. The card was so gimped it couldn't do anything.

    Just wondering if anybody has gotten the Ralink chipset working with BT4?
    And if BT4 has any correlation with the Rtx00 project drivers?

  2. #2
    Senior Member
    Join Date
    Aug 2007


    I believe BT just includes the drivers if and when they are patched, the guys at aircrack-ng does the hard yards of writing injection patches and maybe some BT devs but otherwise it just gets included.

    The chipset can be made to work in bt3, but its alot of work.. with bt4 you can get it compiled more easily, the native driver is available from ralink's website but monitoring and/or injection as I last saw it wasn't capable.

    Not that I own this device btw.

  3. #3
    Just burned his ISO
    Join Date
    Feb 2009


    Quote Originally Posted by hatake_kakashi View Post
    The chipset can be made to work in bt3, but its alot of work..
    Yea I know, I've gone through and done all the steps to get it working and it's still quite gimped. Not that it's a big deal, because I bought probably one of the best known war driving adapters out there.

  4. #4
    Developer muts's Avatar
    Join Date
    Jan 2006


    From what i saw in shmoo, the rt26xx was not working on the 901... We will soon add then to the repos.

  5. #5
    Just burned his ISO
    Join Date
    Aug 2008


    in ralink drivers for linux there is a file called iwpriv_usage.txt.

    Inside this file we can read:

    iwconfig ra0 mode {managed|ad-hoc|...} ; set wireless mode
    >> rt2860sta driver support monitor mode with linux kernel > 2.4.20.
    monitor mode is the samething of injection?

    sorry for my bad english.

  6. #6

  7. #7
    Just burned his ISO
    Join Date
    Jan 2010
    Melbourne, Australia


    It is possible to get the Internal Ralink Card in the eeepc 1000h working with BT4 beta
    As always most of the info is available on this forum

    i set up a SD card with persistant changes using HowTo: Set up a USB stick to save changes guide by ktzqbp

    then i downloaded the latest Ralink driver for linux from

    h x x p : / / w w w .

    copied it to the root directory

    then using parts of Installing BT3 on the eee 901 with drivers, part I by hippocrates as a guide

    issued the following commands

    tar xvjf 2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2

    cd 2008_0918_RT2860_Linux_STA_v1.8.0.0

    make install
    cd os/linux
    insmod rt2860sta.ko

    #Check it worked

    Ifconfig –a

    then you can issue the following

    airmon-ng start ra0

    airodump-ng ra0

    monitor mode should be working

    and before anyone asks - no injection isn't supported by this driver

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts