Results 1 to 2 of 2

Thread: BT3 full encrypted on eeePc SDHC problem

  1. #1
    Just burned his ISO
    Join Date
    Jan 2009

    Default BT3 full encrypted on eeePc SDHC problem

    Hi there!
    this post is intended as a reply to hxxp:// this tutorial which explains how to make a BT3 encrypted installation on HD. Unluckily as "newbie" i'm cut off and i cannot reply there. More, i even can't post working URL. sorry :/

    In my eeepc 901 SSD i have installed Ubuntu eee version and I'd like to install BT3 encrypted with luks on my 8Gb SDHC.

    I tried at least three times to complete the tutorial but I am having lots of troubles because it is very confusing to install BT3 in the SDHC using relative /dev/ paths in eeePc 901 since the installation canonly be done by an USB Live BT3, which is read as /dev/sda, that is the same path which the SDHC is read too when rebooting without USB drive. Or, at least, I guess this is the problem.

     --hand copied--
    initrd.gz:  Loading kernel modules from initrd image:
    Using /lib/modules/
    Using /lib/modules/
    Using /lib/modules/
        Reading all physical volumes. This may take a while. . .
        No volume groups found
        No volume groups found
    --then several output lines trying to access sda as scsi device, saying Write Protect is off: assuming drive cache: write through. finishes saying sda: sda1 sda2
    then again --
       No volume groups found
    mount: mounting cryptroot on /mnt failed: No such file or directory
    ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
    You can try to fix it. Type 'exit' when things are done.
    /bin/sh: can't access tty: job control turned off
    In fact, after reboot, i get an error similar to hxxp:// this one, but different, since my cryptsetup is working properly.

    In fact, installing Lilo on the SDHC, pressing Esc at eeepc startup, i could choose the SDHC disk, boot the bt3 kernel, and, when prompted with the error, I could manually open the luks-encrypted partition, manually load lvm, mount the /dev/btcrypt/root on /mnt and then, giving "exit" the boot process continued successfully.
    So, I think the main reason it didn't work was because it couldn't find the right partition to unlock when booting.

    After that, I tried again the installation changing the /dev/-path- options both in the mkinitrd script and in the lilo configuration, but i got the same error.

    So, guessing it was lilo's fault, i decided to use the Grub that was already installed on SSD instead of lilo: I edited the menu.lst file in ubuntu adding the right BT3 hdUUID, initrd, kernel positions. After reboot grub works like a charm, but the BT3 boot process still stops with the same error. More, booting through grub, when I'm asked to manually fix the error, i cannot mount /dev/sda2 (the encrypted partition) anymore because "Command failed: Cannot access device". Trying to umount that gives "No /dev/sda2 mounted partition", but it still exists because fdisk -l lists it correctly.

    So, i think that there's a lot of confusion in what parition cryptsetup has to open and I think all this could be fixed using some kind of UUID disk id number when compiling initrd. Unluckily, i dunno how to do that, and so i'm asking your help.

    My fdisk -l output is below. Please notice that this is very different from the fdisk -l i get during the BT3 USB Live session (from where i install) because it reads the USB drive as sda and the SDHC as sdb.

    Thank you very much for any advice you can give!

    Disk /dev/hdc: 4034 MB, 4034838528 bytes
    255 heads, 63 sectors/track, 490 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
       Device Boot      Start         End      Blocks  Id System
    /dev/hdc1   *           1         490     3935893+ 83 Linux
    Disk /dev/hdd: 16.1 GB, 16139354112 bytes
    255 heads, 63 sectors/track, 1962 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
       Device Boot      Start         End      Blocks  Id System
    /dev/hdd1               1        1962    15759733+  5 Extended
    /dev/hdd5               1        1962    15759702  83 Linux
    Disk /dev/sda: 8068 MB, 8068268032 bytes
    255 heads, 63 sectors/track, 980 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
       Device Boot      Start         End      Blocks  Id System
    /dev/sda1               1          33      265041  83 Linux
    /dev/sda2              34         980     7606777+ 83 Linux
    Disk /dev/sdb: 2032 MB, 2032140288 bytes
    255 heads, 63 sectors/track, 247 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

  2. #2
    Just burned his ISO
    Join Date
    Feb 2009


    Hi, make sure you add the scsi and usb storage modules to the mkinitrd line

    it's a great tutorial. works like a dream

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts