View Full Version : BT3 beta on Vostro 1500

02-21-2008, 04:48 PM
I have BT3 beta loaded as a bootable iso on my usb drive. I'm really impressed with the operating system in general. Out of the box the live cd works better then even ubuntu. But I am having some problems.
I haven't used linux intensely, but I have used it a bit so I can get around.
My first question is how can I make the usb drive read/writable so that I can save any changes I make to the operating system? Customizing settings, installing new drives, etc.
Next, my wireless card in my laptop has is the IPW 3945. After reading a lot on these forums about my chipset I'm a bit stuck. First, basic internet is not able to load. Unfortunately I only have one connection to test with so I can be sure it's not a problem with me. I can open the wireless manager, I can see a list of networks, but when I try to connect, it fails.
Now on to the real reason I have backtrack. I'm trying to learn how to gain access to WiFi networks. I've read a few guides, like this one (I am not allowed to post URL's because of my current post count but a quick google search for Mateti Wireless Hacks will return the correct page), and I believe i understand the basic concepts. Also from reading on this forum, I believe I need to load a secondary set of drivers so that I may do things like injections. Using the links in the "start menu" of back track I have tried opening "Load IPW 3945/4965" as well as "Load IPWRAW". Both times I get an error.
When I run Load IPW 3945/4965 I get:

/bin/sh: ./unload: No such file or directory
/bin/sh: ./load: No such file or directory
Error: Module ipraw does not exist in /proc/modules

and for Load IPWRAW i get:

Error: Module ipraw does not exist in /proc/modules
/bin/sh: ./unload

Now finally, I am unable to open Kismet. I'm sure it is a problem with my drivers but I just find it strange that when I click the link in the start menu, nothing happens.

Unfortunately my linux knowledge is limited so I'm not sure how to resolve these issues. Any help is very appreciated. Thanks in advance.

02-21-2008, 05:10 PM
For the links in the kde menu I posted a fix on the wiki. The ipraw drivers are ONLY for injection. The illwifi drivers are for surfing the net.


All you need to do is search the tutorial section to find a lot of different guides which deal with how to save changes on a usb.