View Full Version : blackscreen after startx, cannot install backtrack 5 r2 (ati powercolor hd5850)

03-19-2012, 02:41 PM
Hey people,
I hope someone can help me; When i'm starting with the backtrack DVD and typing startx to start and install it, i always get a blackscreen. My grafic card is ati powercolor hd5850, i think this causes the problem.
I also tried to install with USB and follows any usefull tutorial, which were posted from others, who has a similar problem, but nothing helps me !
With the VM Oracle on windows 7 it works fine without any problems.
I will be very happy, if someone helps me. I tried every way and i am very frustrated !!!

03-20-2012, 06:59 AM
p0cTeam's method worked for desktop hd 5770.

After installation, before running startx, install new drivers for the vga.

03-20-2012, 03:56 PM
Thanks for reply, my friend !
The problem is that i cannot install. After booting with the DVD and typing startx the first time i get a blackscreen.
Or is there a way to install it ???

03-21-2012, 03:00 AM
Thank you very much !

It works, but before installing.

But now i get another problem:

Everything is too slow. I try to install jockey-gtk, and follow the link from backtrack (http://www.backtrack-linux.org/wiki/index.php/Install_OpenCL), but it didn't want to work. There is a problem with the fglrx ?!
I try to install fglrx manually, update & upgrage me system. No, No...

And now after making this:
root@bt:~# wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-2-x86.x86_64.run
root@bt:~# chmod +x amd-driver-installer-12-2-x86.x86_64.run
root@bt:~# ./amd-driver-installer-12-2-x86.x86_64.run
root@bt:~# reboot

startx doenst work, it gives me an error message and the system is only in the terminal...

I hope there is someone, who can help me :(


03-21-2012, 06:39 PM
Ok, after long (about 4-5 hours) trying and doing i also solved that problem !
I uninstalled all fglrx drivers and install the newest amd drivers again and o some fixes... It works now, with best grafical perfomance (openCL...).

If i can help someone, i'll do my best...

Best regards

03-21-2012, 07:42 PM
I have the same problem, HP dv6-3030tx with radeon HD5650. The only way I've managed to make it work so far was to copy xorg.conf.failsafe to xorg.conf. After successful install with 'xforcevesa noapic noapci nosplash irqpoll' and reboot I installed the 12-2 driver and ran 'aticonfig --initial', but on reboot got 'no screens found' error. Modified GRUB_CMDLINE_LINUX_DEFAULT line in 'etc/default/grub' to replace 'vga=791' to 'radeon.modeset=0' and ran update-grub, but didn't make a difference. Then when I ran the recovery mode and reset to use failsafe graphics mode, upon 'startx' the computer showed a blank screen and a flashing caps lock, as when it did when I tried to first install it without the extra parameters. So replacing xorg.conf with xorg.conf.failsafe made it useable, but with no video acceleration (which is not too big a deal at the moment, but I'd like to improve the situation later). There is a video fix which I haven't yet tried due to time constraints so cannot confirm whether it works for radeon cards:


And another thing I'll be trying out when there is time is:


I don't know if that last one is gonna do anything, but can't think of anything else at the moment. No doubt there will be a fix sooner or later.

03-22-2012, 11:02 AM
Thanks for reply, my friend !
The problem is that i cannot install. After booting with the DVD and typing startx the first time i get a blackscreen.
Or is there a way to install it ???
yeah, sorry, i must have confused you with a missing full stop, I'll edit it. Anyway good to hear that its working now.

03-23-2012, 06:30 AM
Hey gypsy, do you think you could tell me what fixes you applied after reinstalling the ati driver? I've purged and reinstalled it a couple of times, but it absolutely refuses to work - keeps giving me "no screens found" error. I can only use the failsafe config with no video acceleration. Lost the count of hours I've spent trying to get it working, no success yet. With the BT5-R1 there was some simple setting that fixed this exact problem, but so far I've tried everything and no luck. Thanks.

03-24-2012, 03:21 PM
Sorry for the late response !

I've followed the introductions from this link: http://www.backtrack-linux.org/wiki/index.php/Install_OpenCL !
What is exactly your problem, which errors do you get - perhaps i can help you ?!?

Best regards

03-28-2012, 01:54 AM
Ok the thing is, that I keep getting "Fatal server error: no screens found" upon typing startx whenever I use aticonfig to generate a configuration file. I also followed that same guide and tried to run it, and then again tried reinstalling the driver, but it keeps happening regardless. So far the only way I can get in the desktop is by removing xorg.conf, or making a copy from xorg.conf.failsafe. When I get this error, straightaway checking /var/log/Xorg.0.log shows a couple of errors:

(WW) PowerXpress feature is not supported on A+I Mux Platform. Please uninstall fglrx driver.
(EE) no devices detected

in some other instance:
(EE) GLX error: can not get required symbols

PowerXpress is the thing that lets you switch between discrete and integrated graphics AFAIK, so I decided to try and switch them manually and followed this guide, which includes recompiling the kernel with added VGA switching support:

Doing that had a couple of effects: first, appending things like "radeon.modeset=0", or "nomodeset" to the /etc/default/grub file now had an effect (changed display resolution, some drivers cannot be loaded if modesetting is in use), whereas it didn't before. Second, now the screen resolution returned to normal (before the screen edges were outside the monitor with no option to change resolution), and now the brightness can be adjusted. But the "no screens found" error is still there. In the end, the computer does not seem to be able to use fglrx driver at all. I've tried changing the driver to "radeon" in xorg.conf; using i915/radeon/fglrx modesets 0/1 (and not using them), and all the aforementioned fixes with no success.

Looking at Xorg.0.log makes me think that it has something to do with BIOS of this particular card, as all the question marks next to BIOS there seem to suggest:

(--) PCI: (0:1:0:0) 1002:68c1:103c:144a ATI Technologies Inc Madison [AMD Radeon HD 5000M Series] rev 0, Mem @ 0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072

Majority of error messages associated with Radeon cards that I've seen appear to be very similar, but where some have an easy fix others do not seem to have fixes at all, which probably depends on the specific card. I appreciate your help, but don't worry if you can't think of anything - there might not even be a solution. Thanks.