View Full Version : cant connect to msfrpcd

05-12-2011, 04:12 PM
when i use # msfrpcd -P toortoor -U msf -a
(its either socket error or auth error, depending on starting method of msfrpcd)

i get:

XMLRPC starting on (SSL):Basic...
XMLRPC backgrounding at 2011-05-12 18:05:04 +0200...
root@bt:~# /opt/framework3/msf3/lib/active_support/dependencies.rb:429:in `rescue in load_missing_constant': uninitialized constant Rex::Parser::Ini (NameError)
from /opt/framework3/msf3/lib/active_support/dependencies.rb:425:in `load_missing_constant'
from /opt/framework3/msf3/lib/active_support/dependencies.rb:80:in `const_missing_with_dependencies'
from /opt/framework3/msf3/lib/msf/core/module_manager.rb:462:in `set_module_cache_file'
from /opt/framework3/msf3/lib/msf/base/simple/framework.rb:107:in `simplify'
from /opt/framework3/msf3/lib/msf/base/simple/framework.rb:71:in `create'
from /opt/framework3/msf3/msfrpcd:101:in `<main>'

what am i doing wrong and how do i fix it? :(

using gnomex64 @ VMware

[edit] i belive my connectivity is not only to localhost, having trouble resolving hostnames aswell :S

05-13-2011, 01:01 AM
have the same problem bt5 ubuntu...

05-13-2011, 10:49 AM
i solved it by bridging the connection in wmware, im sucha forgettfull noob, that solved 99% of my connectivity problems.. for you i dot know how to solve it

05-13-2011, 01:30 PM
Update the Metasploint Framework fixed it for me...
You could also try to start the XMLRPC Service without "-a" for testing....
So it will connect to