View Full Version : aircrack-ng not recognizing

09-03-2009, 04:17 AM
This may seem very basic and rest assured I have searched, googled, etc and not really found the answer.

I changed the name of my essid to one of the ones found here Church of Wifi WPA-PSK Rainbow Tables - Hak5 Forums (http://hak5.org/forums/index.php?showtopic=12708) and downloaded the file (I named it one of the random 2wires).

However, it is an extensionless file after it downloads. No problem I thought, I'll just point cowpatty at it. Problem is, after it checks about some 3000 passwords it triggers a buffer overflow...uh. I dont think I didnt anything wrong. -d to the rainbow file, -s for the SSID and -r for the handshake

Edit: title should be "cowpatty" realized before I posted not to use aircrack-ng. Changed post. Forgot to change title.
The more I write this, I wonder if it should go in another area...

09-03-2009, 10:36 AM

Did you compile Cowpatty on your own ? If you are on BT4-PF (ubuntu-based), this thread might interest you : [all variants] Cowpatty buffer overflow - Ubuntu Forums (http://ubuntuforums.org/showthread.php?t=978025)

It says that the last version of GCC tries to optimize the code, which leads to buffer overflows. So try to download the cowpatty sources (http://wirelessdefence.org/Contents/Files/cowpatty-4.2.tgz) and fix the makefile such as here : Ubuntu Forums - View Single Post - [all variants] Cowpatty buffer overflow (http://ubuntuforums.org/showpost.php?p=7609342&postcount=7)

Then compile it using "make" and try again (copy the hashes files in the same directory as where Cowpatty was just compiled from)

I think you can also use aircrack with these tables (so as you get back to your thread title :D); Try this :
aircrack-ng -r <hashfile> <capture>.cap

Let us know if it worked :)

09-03-2009, 10:46 AM
. So try to download the cowpatty http://wirelessdefence.org/Contents/Files/cowpatty-4.2.tgz

there is cowpatty 4.6 in bt4pf
BackTrack Information Security Distribution BackTrack 4 Pre Final – Feel the pwnsauce! (http://www.offensive-security.com/blog/backtrack/backtrack-4-pwnsauce/)

09-03-2009, 11:11 AM
Quite interesting, on the official site it's stuck to 4.3... Remote Exploit guys are crazy, they have versions that aren't even available yet :D

But if the 4.6 is embedded in bt4pf, it might cause the problems that snipper_cr mentions, that's why I told him to try to compile it on his own :)

09-03-2009, 06:26 PM
No I didn't compile it on my own, just straight from BT4 live CD. For the heck of it, I copied my .cap file and the rainbow file to another computer that was running BT3 and it worked just fine.

I thought the rainbow tables didn't work in aircrack-ng, just cowpatty.

09-04-2009, 11:31 AM
Aircrack is able to use Rainbow Tables too, but I think that it uses a particular format (use Airolib-ng to create your Aircrack tables), maybe that the oens from Chrurch of Wifi are not compatible...

That's OK if you made it on BT3 :)