Install VBox

From BackTrack Linux
Jump to: navigation, search

Installing VirtualBox in BackTrack5

root@bt:~# wget http://download.virtualbox.org/virtualbox/4.0.10/virtualbox-4.0_4.0.10-72479~Ubuntu~lucid_i386.deb
  • Try to install the .deb package
root@bt:~# dpkg -i virtualbox-4.0_4.0.10-72479~Ubuntu~lucid_i386.deb 
  • You should get a similar error to this:
root@bt:~# dpkg -i virtualbox-4.0_4.0.10-72479~Ubuntu~lucid_i386.deb 
Selecting previously deselected package virtualbox-4.0.
(Reading database ... 219334 files and directories currently installed.)
Unpacking virtualbox-4.0 (from virtualbox-4.0_4.0.10-72479~Ubuntu~lucid_i386.deb) ...
dpkg: dependency problems prevent configuration of virtualbox-4.0:
 virtualbox-4.0 depends on libqt4-opengl (>= 4:4.5.3); however:
  Package libqt4-opengl is not installed.
dpkg: error processing virtualbox-4.0 (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead ...
Processing triggers for shared-mime-info ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-support ...
Errors were encountered while processing:
 virtualbox-4.0
root@bt:~#
  • As we can see we are missing some dependencies, let's quickly solve them:
root@bt:~# apt-get -f -y autoremove
root@bt:~# apt-get install libqt4-opengl libqt4-opengl-dev
root@bt:~# dpkg -i virtualbox-4.0_4.0.10-72479~Ubuntu~lucid_i386.deb 
  • After the install is finished you should be able to start VirtualBox from the Applications Menu -> System Tools -> Oracle VM VirtualBox


Vbox in bt.png


  • Enjoy!