Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49

Thread: BT3 Tutorial : Installing Nessus 3.2.0

  1. #41
    Junior Member
    Join Date
    Feb 2006
    Posts
    25

    Default some progress

    Quote Originally Posted by janus View Post
    Hello everyone,

    great tutorial, thanks for sharing.

    I followed all the instructions and everything works fine until I start nessusclient and I get the following error message:

    /opt/nessus/bin/NessusClient: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory

    I've searched around and can't find an answer to the problem. I updated the QT package again through gslapt but it seems that somehow the libQtXml.so.4: is nowhere to be found.
    Any ideas?




    (I'm using Nessus-3.2.1-fc9.i386.tgz and NessusClient-3.2.1.1-fc9.i386.tgz packages from nessus website and I have Slackware 12.0 and have updated everything through FastTrack).
    Well nothing like DIY tinkering. I compiled and installed the qt4 package manually (apparently that's what the new nessus client uses and it is not in BT3 or available through Gslapt) and updated the ld.conf to point there.

    Now when i run nessusclient i get a different error so some progress but still not there yet:

    /opt/nessus/bin/NessusClient
    /opt/nessus/bin/NessusClient: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/nessus/bin/NessusClient)

  2. #42
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by janus View Post
    Well nothing like DIY tinkering. I compiled and installed the qt4 package manually (apparently that's what the new nessus client uses and it is not in BT3 or available through Gslapt) and updated the ld.conf to point there.

    Now when i run nessusclient i get a different error so some progress but still not there yet:

    /opt/nessus/bin/NessusClient
    /opt/nessus/bin/NessusClient: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/nessus/bin/NessusClient)
    Have you made any changes to BT3 and are you sure that you followed the installation procedure correctly? I have personally installed Nessus on BT3 Final recently using the steps mentioned in this tutorial and did not run into any of the issues you are describing.
    -Monkeys are like nature's humans.

  3. #43
    Junior Member
    Join Date
    Feb 2006
    Posts
    25

    Default

    Quote Originally Posted by =Tron= View Post
    Have you made any changes to BT3 and are you sure that you followed the installation procedure correctly? I have personally installed Nessus on BT3 Final recently using the steps mentioned in this tutorial and did not run into any of the issues you are describing.
    Thanks for the quick reply Tron. I'm pretty sure that I followed all the instructions and everything went smoothly until I ran the nessus client. I'm thinking that that is where the problem might lie (I installed the newest NessusClient-3.2.1.1-fc9.i386.tgz, not the older version in the tutorial). Could you check to make sure you have that same version up and running? I think that the new client needs newer libraries that are found in slackware 12.2 (another poster talked of similar issues that went away after upgrading to 12.2 but I'm too lazy for that at the moment) like the qt4 and newer glibc packages.
    The nessus site only provides download to the 3.2.1.1. fc9 version of the client. Anyone have a slightly older version that is working with BT3?

  4. #44
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by janus View Post
    Thanks for the quick reply Tron. I'm pretty sure that I followed all the instructions and everything went smoothly until I ran the nessus client. I'm thinking that that is where the problem might lie (I installed the newest NessusClient-3.2.1.1-fc9.i386.tgz, not the older version in the tutorial). Could you check to make sure you have that same version up and running? I think that the new client needs newer libraries that are found in slackware 12.2 (another poster talked of similar issues that went away after upgrading to 12.2 but I'm too lazy for that at the moment) like the qt4 and newer glibc packages.
    The nessus site only provides download to the 3.2.1.1. fc9 version of the client. Anyone have a slightly older version that is working with BT3?
    Just fired up BackTrack and I am running version v3.2.1 (build 2G295_Q) without any problems whatsoever. Apparently you have not followed the tutorial to the dot as you are supposed to get the Fedora Core 8, and not 9, versions of the RPMs.
    -Monkeys are like nature's humans.

  5. #45
    Junior Member
    Join Date
    Feb 2006
    Posts
    25

    Default

    Thanks. Will try it later with the fc8 packages and will let the forum know to help out others who download the latest packages instead of the exact versions in the tutorial. I suspect that upgrading to slackware 12.2 resolves the issues with missing libraries.

  6. #46
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    Quote Originally Posted by janus View Post
    Thanks. Will try it later with the fc8 packages and will let the forum know to help out others who download the latest packages instead of the exact versions in the tutorial. I suspect that upgrading to slackware 12.2 resolves the issues with missing libraries.
    I am positive that the error is related to the fact that you used the fc9 instead of the recommended fc8 packages, but please give it a try and post back your results.
    -Monkeys are like nature's humans.

  7. #47
    Junior Member
    Join Date
    Feb 2006
    Posts
    25

    Default

    Well, I installed the fc8 packages and this time it seems to be working although I do get this error when running nessus client even though the gui loads apparently fine:

    /opt/nessus/bin/NessusClient
    /opt/nessus/bin/NessusClient: /usr/lib/libpng12.so.0: no version information available (required by /opt/nessus/lib/libQtGui.so.4)

    Maybe all my installing and uninstalling the packages messed something up. Too tired right now to investigate further.
    Thanks again for your help and please do let me know how to fix this error if you have any idea.

  8. #48
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    5

    Default

    Very well explained, even with 3.2.1, no problems during installation or configuration. They emailed my the key in a few minutes.

    Thanks!

    Is it a full version? i mean, how much last the key?

  9. #49
    Good friend of the forums williamc's Avatar
    Join Date
    Feb 2010
    Location
    Chico CA
    Posts
    285

    Default

    Janus, the error was discussed on the first page. Its an issue with the library file not listing its version information. It happens on mine too.

    MAGSPAIN, this is the full version, but with a delay in the updates. It should last indefinately, or until they phase out 3.2.

    William

Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •