Results 1 to 5 of 5

Thread: 2915abg

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    10

    Default 2915abg

    I've read the wiki and I have done what I can to follow steps precisely. My problem is that I can not get the packet injection to work. I successfully boot to backtrack using from a USB thumbdrive.

    airmon-ng start eth1
    it says "monitor mode enabled" Oddly, when I enable the monitoring, the name does not change

    airodump-ng eth1
    it finds my (and other) access points and shows my beacons

    aireplay-ng -9 eth1
    Trying broadcast probe requests...
    No Answer...

    I made sure airmon-ng was using the same channel as my AP - airmoin-ng start eth1 11 check kill

    When I run iwconfig it says Mode:Monitor

    I am told that I should not see eth1, I should see mon0, or something like that.

    My card is an Intel 2915ABG. According to the wiki for compatibility drivers it says ipw2915 uses ipw2200 driver. It also references a tutorial - Basic injection with ipw2200 and BackTrack v2 for beginners which references further updates to be made to do injection. Are these updates already in Backtrack?

    Any ideas?

  2. #2
    Junior Member creepykrawler's Avatar
    Join Date
    Jan 2010
    Location
    USA
    Posts
    56

    Default Re: 2915abg

    It looks like you are trying to run your commands against the on board NIC. Can you post the output of

    iwconfig

    After you have your wireless card installed.
    "Failing to plan is planning to fail"

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    10

    Default

    Quote Originally Posted by creepykrawler View Post
    It looks like you are trying to run your commands against the on board NIC. Can you post the output of

    iwconfig

    After you have your wireless card installed.
    I am not sure what you mean by "after you have your wireless card installed",

    This is my airmon-ng results:

    Code:
    root@bt:~# airmon-ng start eth1
    
    
    Interface       Chipset         Driver
    
    eth1            Intel 2200BG    ipw2200 (monitor mode enabled)
    My iwconfig results:

    Code:
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      unassociated  ESSID:off/any
              Mode:Monitor  Frequency=2.457 GHz  Access Point: Not-Associated
              Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Additional information about my issue:

    From dmesg:

    Code:
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    ipw2200: Copyright(c) 2003-2006 Intel Corporation
    ipw2200 0000:14:02.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
    ipw2200 0000:14:02.0: firmware: requesting ipw2200-bss.fw
    input: ThinkPad Extra Buttons as /class/input/input6
    ipw2200: Detected geography ZZA (11 802.11bg channels, 13 802.11a channels)
    Is there any other troubleshooting data that would help me determine my problem?
    Last edited by Archangel-Amael; 02-05-2010 at 11:45 AM.

  4. #4
    Junior Member creepykrawler's Avatar
    Join Date
    Jan 2010
    Location
    USA
    Posts
    56

    Default Re: 2915abg

    Oh, I was assuming this was a usb dongle. I guess it is internal. Do you have a wireless usb dongle you can put in to test and see if it works and not use the internal wireless? First time I have seen a wireless interface with the ethX name....you should have wlan0/wlan1...etc and when you run airmon-ng start you should get a mon0 or a mon1 interface.... Good luck!
    "Failing to plan is planning to fail"

  5. #5
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    10

    Default Re: 2915abg

    Quote Originally Posted by creepykrawler View Post
    ...First time I have seen a wireless interface with the ethX name....you should have wlan0/wlan1...etc and when you run airmon-ng start you should get a mon0 or a mon1 interface.... Good luck!
    creepykrawler - good info - that should help my research, thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •