Results 1 to 4 of 4

Thread: I've lost my BackTrack kmenu structure

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    3

    Default I've lost my BackTrack kmenu structure

    Hi, I've been running BT3 as a hard disk install for a couple of months, with a few little issues that I won't go into, but mostly pretty good.

    recently I installed MinGW and some time after that I noticed that my kmenu had changed from the normal backtrack structure to another more generic structure with an entry for wine under which was MinGW and nothing else.

    I did some googling and searched the forum but I didn't really know what I was looking for. (never played with the menus before) I found a suggestion on another forum to delete the .kde directory under root this of course made it worse, then I found a thread in here talking about .config/menus I did some playing around with that the stuff in applications-kmenuedit.menu seems to be all the right things in the right structure... but I'm at a bit of a loss now as to how to get it read...

    any advice would be appreciated

  2. #2
    Member imported_Deathray's Avatar
    Join Date
    Oct 2007
    Posts
    381

    Default

    The easy way to solve this problem would be to
    copy the appropriate config files for KDE menu from a live BT3,
    over to your hard disk install. Sorry I can't inform you as to
    where these files are, as I have no idea myself :b .
    But I'm sure it's possible.

    Good luck
    - Poul Wittig

  3. #3
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    3

    Default

    Yeah... that's what I figured , but I' struggling to work out which ones they are...

    I've done the whole /root/.kde directory and parts of /opt/kde/ but no joy...

  4. #4
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    3

    Default

    well, in case anyone else has the same problem and stumbles across this thread
    I discovered a bunch of stuff about KDE menus and this site was very helpful

    h t t p ://people.fruitsalad.org/phil/kde/userguide-tng/kde-menu.html (sorry for the formatting the n00b isn't allowed to post URL's)

    but ultimately
    in /etc/xdg/menus there was a file called applications.menu which wasn't in the live cd
    I renamed this to applications.menu.bkp

    and my menus were all good

    YAY

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •