Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Downgrade to Kernel 2.4 possible?

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    4

    Default Downgrade to Kernel 2.4 possible?

    Hi
    Iīve a DWL 122 USB dongle and its driver (injection) works only with 2.4 kernels.

    So I want my BT3īs kernel to 2.4!

    Can you tell me if itīs working? With slapt-get? Can you tell me where to download the kernel?

    Or the whole command? Please help me Iīm trying for 5 days noe!!!

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    I'm sure it can be done. You're probably going to have to recompile most of the applications though.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  3. #3
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    4

    Default

    is it hard work? is it difficult? sure that i have to compile the aircrack suite? can i use this one from ftp.kernel.org: linux-2.4.36.2.tar.gz ??


    please help me!

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    It's really not worth it. If you want the 2.4 kernel, use BT2. Pretty sure that's the kernel it's using.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  5. #5
    Member
    Join Date
    Jun 2007
    Posts
    218

    Default

    BT2 is using the 2.6.20 kernel.

  6. #6
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Quote Originally Posted by level View Post
    BT2 is using the 2.6.20 kernel.
    Yea, looks like you're screwed then. You can try using another kernel, but like I said, you're going to have to recompile pretty much the entire distro. Really not worth it. I don't see why your wifi card doesn't work now with the new kernel, they usually don't take stuff out.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  7. #7
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    4

    Default

    Are u 100% sure?? I installed today even Backtrack v1.0 and it says 2.6.x.x when i typed "uname -r"


    I googled:
    Kernel 2.6.20 <> Backtrack 2
    Kernel 2.6.15.6 <> Backtrack 1

    EDIT: Oh posted the same time

  8. #8
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    4

    Default

    Quote Originally Posted by Barry View Post
    I don't see why your wifi card doesn't work now with the new kernel, they usually don't take stuff out.
    Because injeciton only works with 2.4 kernels...

    Iīve the dwl 122 d-link... quote backtrack wiki: "Notice : There are drivers for injection however they only work on 2.4 kernels. Can be found here [9]"

    what should i dooo???

  9. #9
    Member wick86's Avatar
    Join Date
    Mar 2010
    Posts
    113

    Default

    Quote Originally Posted by Rufioo View Post
    Because injeciton only works with 2.4 kernels...

    Iīve the dwl 122 d-link... quote backtrack wiki: "Notice : There are drivers for injection however they only work on 2.4 kernels. Can be found here [9]"

    what should i dooo???
    I suggest you get a new wireless card because like Berry says it would be a nightmare trying to recompile every thing and probable a wast of time.

  10. #10
    Just burned his ISO
    Join Date
    Oct 2006
    Posts
    1

    Default

    I also have the D-Link DWL-122, now I'm using KisMac to authenticate and inject packets, but it's not so stable.

    Is it maybe an option to install an Ubuntu version with kernel 2.4.xx? And then install the right driver + patch for Prism 2?

    Or is there someone who still has an very old Backtrack with 2.4 kernel? That would be great..

    Thanks already

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •