Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: OpenOffice in BT3

  1. #1
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default OpenOffice in BT3

    Alright I have had like 10 requests and read a few threads all asking about openoffice in bt3. Why I'm not sure because I would never do my homework in backtrack but here it is anyway. Funny story though I did get caught missing a short paper a few weeks ago and all the computers at the school library were full and I had like 40 mins to get a 500 word esay done. I look in my bag and all I got is the eeepc. Well I fired it up and cranked it out real quick. Thats how this tut came about because I needed something with spell check and I had to get online and figure out how to install open office real quick. Also the paper had to be emailed in windows format so I had to move quick. Anyway its easy so here it is.

    The version of openoffice that worked for me is located here
    Just choose http or ftp over to the right and pick a location near you.

    Once you get it simply use installpkg like this

    Code:
    bt ~ # installpkg openoffice.org-2.3.1-i586-1kjz.tgz
    This will not add menu links youll have to do that on your own. The start up command is...
    Code:
    bt ~ # openoffice.org2.3
    I18N: Operating system doesn't support locale "en_US"
    It will complain with that error which I don't understand yet but the program works fine.

    Well wasn't much of a tutorial but there it is Cheers, Pureh@te

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by pureh@te View Post
    Code:
    bt ~ # openoffice.org2.3
    I18N: Operating system doesn't support locale "en_US"
    It will complain with that error which I don't understand yet but the program works fine.

    I found this:
    issue the following the solve the "problem"

    as root:

    # cd /usr/share/locale
    # ln -s en_US.ISO8859-15 en_US

    that should solve the "problem"
    maybe that will do it ?
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Thanks but that did not fix it however I just created a menu entry in the kde menu and I left run in terminal unchecked and the error is never seen. Out of sight out of mind

  4. #4
    Senior Member
    Join Date
    Feb 2008
    Posts
    681

    Default

    I've been intending to install open for a while now.

    Thanks for the guide
    [FONT=Courier New][SIZE=2][FONT=Courier New]hehe...
    [/FONT][/SIZE][/FONT]

  5. #5
    Member
    Join Date
    Mar 2010
    Posts
    57

    Default

    but in my pc i cant install openoffice it say....

    cannot install openoffice bcuz thats not end with .tgz

    but the file is in .tgz format id download the openoffice in this site linuxpackages.net can someone tell me where i get wrong....

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Wow. Obviously English is not your first language so you are going to need to document and post your exact steps and I will try to help.

  7. #7
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    6

    Default Cant Install

    I am having the same problem as the guy with the great English. I type installpkg openoffice.org-2.3.1-i586-1kjz.tgz into the console and I get the response, Cannot install openoffice.org-2.3.1-i586-1kjz.tgz: package does not end in .tgz. I have made sure that I am typing the file name correctly. I have also tried installing with pkgtool. I have also tried downloading the file from a different server, and get the same results. Thanks for any help.

  8. #8
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    1

    Default

    For those of you who can't install OpenOffice due to the "doesn't end with tgz" "error" even though it is a .tgz, here is a solution:
    move the file you downloaded to your root!

    That did it for me

    Oh, and btw, i am a complete n00b just got my backtrack 3 to work and it's great, great "guide" to OpenOffice to work. Thanks Pureh@te, your the man.

  9. #9
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by pureh@te View Post
    Well wasn't much of a tutorial but there it is Cheers, Pureh@te
    Worked like a champ for me.
    "\x74\x68\x65\x70\x72\x65\x7a\x39\x38";

  10. #10
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    6

    Default

    Thats not working for me either. Any other ideas? Thanks.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •