Results 1 to 4 of 4

Thread: Kismet and my headache.

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    2

    Exclamation Kismet and my headache.

    OK heres the deal. I'm fairly new to Linux and I have been attempting to boot kismet.

    The problem is every time I load up my console and type in kismet I get the following error message.

    Launching kismet_server: /usr/local/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: No packsources were enabled. Make sure that if you use an enablesource line that you specify the correct sources.
    Done.



    I have literally been up for 4 hours trying to resolve this issue. Like I said I'm FAIRLY new to Linux and am having trouble editing the conf scripts.

    If anyone has the solution to this I will be eternally in your debt!!

    I would really appreciate any input or pointers on where im going wrong

    I'm using an Atheros AR5005G Wireless Network Adapter card which seems to be working fine with backtrack 2 as I'm currently using the OS to write you this message.

    Once again thanks to anyone who can help me.

    Monica


    PS. i know there are 2 similar thread with this same problem, i searched.... but I didnt find the solution

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Hi monica, Welcome to the forums.

    I'm in a good mood this morning and I will skip the usual new member hazing. I will tell you that normally a little more searching on your part would be best before posing a simple question such as this. I only say this because it has been covered at least 20 times just this year. So first off, reading some documentation on kismet would probably be good. That can be found here

    Secondly what you need is to tell kismet your wireless card (source). This is done by editing the kismet config like this

    bt~#nano /usr/local/etc/kismet.conf
    Go down a bit till you find this part....
    Code:
    # Sources are defined as:
    # source=sourcetype,interface,name[,initialchannel]
    # Source types and required drivers are listed in the README under the
    # CAPTURE SOURCES section.
    # The initial channel is optional, if hopping is not enabled it can be used
    # to set the channel the interface listens on.
    # YOU MUST CHANGE THIS TO BE THE SOURCE YOU WANT TO USE
    source=none,none,addme
    And replace the source line with

    source=madwifi_g,wifi0,madwifi

    Then hold down control and o to exit and save.


    The price of this information is that the next time you see it asked you may answer so some of us that answer it all the time do not have to.

    Cheers,

  3. #3
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    Also, look for the kismet startup script fix in the BT3 section.
    You'll then have the auto-configure working again, so if you use different cards you can just select the appropriate one when you start kismet.

    Although I should also note that actually knowing what the issue is and how to configure it manually (as above post) is the way to go first

  4. #4
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    20

    Default

    Quote Originally Posted by pureh@te View Post
    bt~#nano /usr/local/etc/kismet.conf
    I'm just going to ask a quick question here rather then going and creating a new thread about it...

    whats the purpose of some of the config files being under /usr/local/etc rather then /etc/? Is it just a distro specific quirk? or is a place to put non system related configs?

    I just got kismet working about an hour ago because of this thread, but it did take me a while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •