Results 1 to 5 of 5

Thread: Adduser, login as user, startx = doesn't work

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    1

    Default Adduser, login as user, startx = doesn't work

    So I have installed BT3 on my asus eee's ssd harddrive using the tutorial on i-hacked dot com

    everything works great initially. then I create a user, logout of root, and login as user. when I type startx I get this error:

    xf860OpenConsole: Cannot open/dev/tty0 (Permission denied)

    any idea on how to fix this? I don't want to have to be logged in as root all the time. also, when I am logged in as user, and I type su root, password, it says "sorry," and goes back to #.

    thanks in advance.

  2. #2

    Default

    Well, I don't know for sure because I haven't experienced this, but if it says "Permission denied" for the file/folder /dev/tty0, then simply login as root instead, open a command console, and type
    sudo chmod 777 /dev/tty0 #(or however much permission you want to give it)

    That will make it entirely executable, readable, and writable by everyone (a bit dangerous, so give it your value that you desire - that just makes it failsafe permission wise in the sense that there is no way you can't run it because of permissions).

    -Stephen

  3. #3
    Just burned his ISO
    Join Date
    May 2007
    Posts
    7

    Default

    same problem by me

    i use this steps add a user like root style

    adduser f4r3l
    cp -Rfv /root/{.kde*,.local,.qt*} /home/f4r3l
    chown -Rv f4r3l:users /home/f4r3l
    sudo chmod 777 /dev/tty1

    then login as f4r3l and startx lokk like this

    X Window System Version 1.3.0
    Release Date: 19 April 2007
    X Protocol Version 11, Revision 0, Release 1.3
    Build Operating System: Slackware 12.0 Slackware Linux Project
    Current Operating System: Linux bt 2.6.21.5 #2 SMP Sat Aug 25 19:01:21 GMT 2007 i686
    Build Date: 09 May 2007
    Before reporting problems, check X.Org Wiki - Home
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 10 11:25:57 2008
    (==) Using config file: "/etc/X11/xorg.conf"

    Fatal server error:
    xf86OpenConsole: Cannot open virtual console 7 (Permission denied)


    giving up.
    xinit: Connection reset by peer (errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server error.


    whats the problem ??

  4. #4
    Senior Member Thorn's Avatar
    Join Date
    Jan 2010
    Location
    The Green Dome
    Posts
    1,509

    Default

    Quote Originally Posted by holdmypocket View Post
    So I have installed BT3 on my asus eee's ssd harddrive using the tutorial on i-hacked dot com

    everything works great initially. then I create a user, logout of root, and login as user. when I type startx I get this error:

    xf860OpenConsole: Cannot open/dev/tty0 (Permission denied)

    any idea on how to fix this? I don't want to have to be logged in as root all the time. also, when I am logged in as user, and I type su root, password, it says "sorry," and goes back to #.

    thanks in advance.
    Quote Originally Posted by Viper_2020 View Post
    same problem by me

    ...

    whats the problem ??
    The problem would seem that both of you have forgotten that BT is designed for a specific job (pen testing) and is not a general *nix disto.

    The conventional wisdom is that you run as a regular user under *nix to do everything, except those jobs where you have to be root. For those things you switch to be root via login or su/sudo. The conventional wisdom is great advice for conventional distros, but BT is not a conventional distro. It is designed from the ground up to be a security tool and nothing else. Much of the toolsets on BT require root privileges to work correctly, and as such few (if any) are implemented for use as user with a lower privilege set.
    Thorn
    Stop the TSA now! Boycott the airlines.

  5. #5
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    1

    Default

    this helped me, had the same problem

    The problem is with the permissions on /usr/X11R6/bin/Xorg

    Doing this $ chmod u+s /usr/X11R6/bin/Xorg
    and confirming /usr/X11R6/bin/Xorg file
    owner as root.root will do the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •