Hi Folks,

I am running BT3 for a few weeks now and installed it to my HDD. I'm new to the whole Linux community and BT is the first client i stuck with longer than a few days .
But as I tried to install some programs I got always a problem I could use some help with.

Lately I downloaded XEmacs and followed the installation guide exactly. The first few steps work perfectly fine. But as soon as i type "make" I get a couple of Errors which I not really understand.

Code:
cd ./lib-src && make all
make[1]: Entering directory `/usr/src/xemacs-21.4.0/lib-src'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/src/xemacs-21.4.0/lib-src'
cd ./lwlib && make all
make[1]: Entering directory `/usr/src/xemacs-21.4.0/lwlib'
gcc -c -g -O3 -Wall -Wno-switch -Winline -Wmissing-prototypes -Wshadow -Wsign-compare  -I. -DHAVE_CONFIG_H -I/usr/X11/include xlwmenu.c
xlwmenu.c:39:28: error: X11/bitmaps/gray: No such file or directory
xlwmenu.c: In function 'close_to_reference_time':
xlwmenu.c:351: warning: comparison between signed and unsigned
xlwmenu.c: In function 'XlwMenuInitialize':
xlwmenu.c:3014: error: 'gray_bits' undeclared (first use in this function)
xlwmenu.c:3014: error: (Each undeclared identifier is reported only once
xlwmenu.c:3014: error: for each function it appears in.)
xlwmenu.c:3015: error: 'gray_width' undeclared (first use in this function)
xlwmenu.c:3015: error: 'gray_height' undeclared (first use in this function)
make[1]: *** [xlwmenu.o] Error 1
make[1]: Leaving directory `/usr/src/xemacs-21.4.0/lwlib'
make: *** [lwlib] Error 2
It always looks something like that. I can do "./configure" without problems but I just can't use "make".


I hope I could make my problem clear and someone could help me.

PS: please excuse my crappy school English