Results 1 to 4 of 4

Thread: upgrading ...Apache Server on BT2

  1. #1
    Just burned his ISO
    Join Date
    Aug 2007
    Location
    London
    Posts
    8

    Default upgrading ...Apache Server on BT2

    First of all thank so much for pureh@te's input on this as i tried his suggestion to use package tools but that didn't yield all positive results.

    Here's what i've done:

    -I downloaded source tgz from Apache website and then followed these directions.

    Get the source from h!!p://httpd.apache.org/download.cgi ( httpd-2.2.4.tar.gz ). These instructions are known to work with all Apache versions.
    unpack, configure, compile

    Go to the directory with the downloaded file and enter:
    # tar -xzf httpd-2.2.4.tgz
    # cd httpd-2.2.4
    # ./configure --prefix=/usr/local/apache2 --enable-so --with-included-apr
    # make
    # make install

    Then , I get errors during installation and the process reverses back after make

    - I also tried to convert source to lzm modules so i could insert in the live filesystem.
    - lzm module installed succesfully ... i can see the folder (with installed files)
    but when i invoke the server i get some error messages:

    #httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    #(98)Address already in use: make_sock: could not bind to address [::]:80
    #(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    #no listening sockets available, shutting down
    #Unable to open logs

    So i shutdown the server and restarted again. Pointing the browser to 127.0.0.1 or localhost doesn't get any results either. i have tried to configure httpd.conf several times too

    Also, when i check for version

    #httpd -V
    it says older version is installed...

    pls cold some one point towards a solution as i would not like to mess up my installation.

    All help is much appreciated.
    Thanks

    ps - it's BT2 installed on hard drive using tut by Balding_Parrot.

  2. #2
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    So you said your install didn't work correctly and you converted the sources to a lzm module?

    Converting it to lzm doesn't mean that it gets compiled and installed.

    The first errormessage says, that you didn't configure the server completly.

    The other two say that an application is already running and using port 80.

    Look for a LAMP tutorial, might help you out.
    Tiocfaidh ár lá

  3. #3
    Jenkem Addict imported_wyze's Avatar
    Join Date
    Jul 2007
    Posts
    1,543

    Default

    Obviously you need to go through and configure the apache2.conf file.
    dd if=/dev/swc666 of=/dev/wyze

  4. #4
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default

    1) If you do a "which httpd" what does it tell you?
    2) If you do a "netstat -a" what is listening on port 80 (preventin apache 2 from listening on that port)
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •