Had a few problems today with updating, if you update kde to 3.5.9 you will have to reinstall qt and sip.

Code:
slapt-get --update;slapt-get --install --reinstall qt sip
May help somebody