Results 1 to 3 of 3

Thread: Installing Xvidcap

  1. #1
    Junior Member
    Join Date
    Sep 2007
    Posts
    28

    Default Installing Xvidcap

    Hey guys. I am in need of some help and maybe someone could send my in the correct direction.

    So i am trying to install xvidcap on BT3 and for some reason i cant figure it out. I have read the install documentation and the readme documentation and it really didnt help me much. I downloaded the package and untarred it.

    After i finished that i do a ./configure it looks like everything goes through normally but when i do "make" this is a chuck of what i get.

    Code:
    object_get_type'
    app_data.c: In function 'xvc_appdata_validate':
    app_data.c:529: warning: unused variable 'max_height'
    app_data.c:529: warning: unused variable 'max_width'
    app_data.c:528: warning: unused variable 'dpy'
    app_data.c: In function 'xvc_error_write_msg':
    app_data.c:2474: warning: embedded '\0' in format
    app_data.c:2481: warning: embedded '\0' in format
    app_data.c:2481: warning: embedded '\0' in format
    app_data.c:2500: warning: embedded '\0' in format
    app_data.c:2500: warning: embedded '\0' in format
    app_data.c: In function 'error_write_action_msg':
    app_data.c:2542: warning: embedded '\0' in format
    app_data.c:2542: warning: embedded '\0' in format
    make[3]: *** [app_data.o] Error 1
    make[3]: Leaving directory `/root/Desktop Recording/xvidcap-1.1.6/src'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/root/Desktop Recording/xvidcap-1.1.6/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/Desktop Recording/xvidcap-1.1.6'
    make: *** [all] Error 2
    that is the bottom of the dialog but the errors are all throughout the entire make process.

    and then of course "make install" fails.

    Could this be because i am tarring this to different directory?

    I am sort of lost and dont really know what to do.

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    You can try the package from the repo HERE

    Once you have the file just do a

    bt~#installpkg (filename)

    Should work.

  3. #3
    Junior Member
    Join Date
    Sep 2007
    Posts
    28

    Default

    THANK YOU PUREHATE!!!!!!!!!!!!!!!

    the newest rc did not have a tgz package so i downloaded the latest final release and used installpkg like you said and it installed it and even put the icon in the mulitmedia window!!!!

    You have just brought an end to days worth of pain!

    thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •